Wireless card getting "excellent" signal strength, but low speed (5.5mbps)

Hi - have a HP tx1000 laptop with a Broadcom 4321AG 802.11 a/b/g/draft-n wi-fi adapter, and a Belkin pre-n router - I have excellent signal strength, but low low low speeds of 5.5 mbps consistently. Is there a setting that needs to be changed somewhere so i can get the full speed from the n card and router? please help!
hodgemAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Peter HartCommented:
It might have excellent signal strength - butthere may be interferance or clashes that cuases retries (ie throughput to drop)
if you have encrypion enabled (WEP,..etc) you can try disabled them to see ift hat helps
haveyou tried plugging in (wired) and testing throughput?
0
gobanCommented:
Each WIFI network will operate on a certain channel numbered 1-11. Changing the channel that your network operates on can help if you are experiencing interference.

First you need to know if there are any networks nearby and what channel they operate on. Download a WIFI network scanner like "netstumbler", and run a scan.

http://www.stumbler.net/

If more then one network is within range, try to use a channel at least 5 numbers bigger or smaller then the numbers you discovered in your WIFI scan.  For example if there were three networks, each network could be assigned as channel 1,6,11 because they are non-overlapping channels, and less interference.

Obviously you may not have control over your neighbor's WIFI network.

Also try switching "speed" modes on your wireless access point. Avoid using proprietary modes like like "SuperG", "MAXg", "125 High Speed Mode" or "SpeedBooster"

Try setting all your equipment to wireless "G" and disabling other modes.
0
hbustanCommented:
Most wireless routers allow you to set the connection speed in their advanced Wireless settings.

So you can usually set the router to only connect at 54Mbps or 11Mbps or whatever speed you want. Try setting that and see if that resolves your issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.