Problem with Quickbooks and RWW on the server of an SBS 2003 R2 box - possibly related?

We have an sbs 2003 R2 server that has quickbooks premier 2006 installed on it.  It's been running fine for a couple years.  Users can't get into quickbooks today - they get an error that the file can't be opened and the error code is -6108,-105.

I try connecting via RWW to the server.  I can log in remotely, it accepts my password but when I try to connect to the server I get 'connectivity to the remote computer cannot be established....'.  RWW on that server has been working fine for a long time also.  I can RWW to desktops no problem.

Microsoft says something else might be using port 4125 (but I can get to the server to sign in, so it's not completely messed up).  I stopped the MAD.exe service and still no luck.

Nothing in the event log about any errors.

Any ideas?
babaganooshAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Probably due to Windows Server 2003 Service Pack 2 getting installed.

http://blogs.technet.com/sbs/archive/2007/06/01/unable-to-rdp-rww-into-the-sbs-server-after-applying-sp2.aspx

Jeff
TechSoEasy
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
babaganooshAuthor Commented:
thanks.  this is an R2 machine that was installed < 1 year ago.  SP2 came out months ago, right?  2 things - I didn;t install it, because I heard it was causing problems (maybe it was this RWW problem!) and did they recently start to push it out / make you accept it?

I run the netstat command you mention in that link and it comes back that nothing is running on that port.  b ut the TS service says it is started (but stop and start are greyed out).

the quickbooks issue seems to be resolved - reinstall on the server and delete the ND files - not sure which solved it but both togethter did it.

0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Just because there are going to be problems doesn't mean that you don't install Service Packs.  Those are never optional if you want to stay in a supported configuration.

See "So why do we NEED Sp2?" here:
http://msmvps.com/blogs/bradley/archive/2007/07/07/so-why-do-we-need-sp2.aspx

Do you not know whether or not SP2 is installed on your server?  It's easy to find out... see the image below.

So, if you're saying that running {{ "netstat -aon | find ":3389 }} " came up empty, they that's your problem.  You'll find the fix for it as well as a few other SP2 issues here:  http://sbsurl.com/sp2

Jeff
TechSoEasy
post.png
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.