Extended desktop on laptop resets after screen saver

G'day all.

  I have a Fujitsu Tablet in a docking station that is connected to a Benq LCD monitor. The included Intel 965 chipset software enables the use of 'extended desktop.' I can do this from the screen (right click) or through control panel/displays.

  All works fine and I have a scheme created 'docked.' When the screen saver activates, or I open Task manager, or I start the computer, the system seems to 'autodetect' and resets to the dual display clone.

 I can right click and restore the extended desktop but as you can imaging this is a pain since all the open apps rearrange through the process.

  I have emailed Intel and they have verified the drivers and software and it isn't causing a prob at their end. SO I have the latest updates to the Intel chipset etc. I have the correct driver for the Benq.

  I even downloaded the Microsoft Hotfix for docking problems and external screens but still no success.

  Any ideas?

  Lloyd.
LloydWAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

scrathcyboyCommented:
YES, simply do NOT activate the screen saver.  Just BLANK the screen for the time you want it blanked -- blanking is not the same as a screen saver, windows just eliminates the image on the screen, not runs a separate program.  It is the running of this screen saver that is conflicting with the dual display.  The screen saver is written to only one screen, and does not abide by the coding standards of a dual display, so it causes a GPF in the OS, that windows is handling internally.  If you blank the screen, no app runs to cause the problem.  I hope this makes sense.  Just choose "blank the screen" from the screen saver choices.
0
LloydWAuthor Commented:
Thanks for that idea. I'll try it. Why would activating Task Manager cause the same issue (ie reversion to dual display)?

  Lloyd.
0
scrathcyboyCommented:
probably because the drivers for the dual display were not debugged correctly, especially for system level tasks that assume there is only one "default" monitor.  WHen you compare top level dual display software, like that written for the Nvidia chipsets on ASUS motherboard graphics, and other high end graphics cards, they do not have this problem, as far as I know, at least my Nvidia software does not,  so you might assume it is just poorly debugged software.  Have you gone onto the MB chipset MFgs website to see if there is a BIOS upgrade or a driver upgrade for the dual display capabiliites of this machine?  If not, check that out.  If you do flash the BIOS, make sure NOT to turn the computer off at the end of flashing.  Be suer to warm boot directly into the OS and run it before turning off.
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

LloydWAuthor Commented:
I'd like to follow this advice, but for security reasons I need to be able to 'lock' the screen if I'm away. The screensaver with password protect delivers this. Is there another option?

I am also surprised that having raised the specific issue with Intel, they went away (according to emails) and checked the chipset and drivers twice and it maintained a stable extended desktop - even to turning off and back on. So I know it is tempting to be scathing of Intel but to me it seems something more of an interaction between windows and the drivers or I need to find a way to 'switch off' the autodetect features of the video card and demand it just follow my scheme.

Lloyd.
0
scrathcyboyCommented:
the "prompt for password when the computer returns from standby" is a built in feature of windows -- under desktop properties, screen save, click power button, check "prompt for ..." and whatever you use, you will have to enter a password.  Now you can go back to the power scheme tabs and set the standby option to be the same time as when your screen saver kicks in -- 5, 10 mins, whatever.  Now go back to the desktop screen saver, and simply choose "blank".  This should do it.

If you still get the same problem, it is going into standby or hibernation that is resetting the display.  If this fixes the problem, it was the (addon?) screen saver that you were using.  Good luck.
0
LloydWAuthor Commented:
Sorry, problem persits.
  I have the screen blanking now, but on resume or when I resume from standby the same pattern occurs - screens flicker and then reset to dual display.

  Regards,  Lloyd.
0
scrathcyboyCommented:
Dual display is an automatic default on many applications, and even the OS, if two displays are connected.  It is possible you will not solve this at all.  A later BIOS update might solve it if they rectify it at the BIOS level.  But I wouldn't hold my breath.  Seems you will have to put up with resetting it, until a fix comes.
0
LloydWAuthor Commented:
Comment noted, but I am stumped as to why none of the OEMs recognise it as a problem or can recognise it. Are they just passing the buck and if so when will I recognise that the bug has been fixed? Do I watch for the bios to be updated (Intel have verified their drivers)?

 Lloyd.
0
scrathcyboyCommented:
Don't know, you can call them, see if this is a known issue, and they will admit it. Waiting for a BIOS update can be a long process, unless they are alerted it is a big problem and they take it seriously.  Good luck.
0
LloydWAuthor Commented:
OK it seems no one has any other ideas apart from scrathcyboy. Unfortunately I don't have a solution (which I would dearly love), and it seems my best option is to take the laptop back to service to see if they can figure it out (which I suspect will be unlikely).

If I don't hear any other ideas in a couple of days I'll close the question.
0
LloydWAuthor Commented:
This issue has been one that has been reviewed by Microsoft, Fujitsu, Intel etc and despite everyone's efforts the problem continued.

Final discovery came when someone pointed out that the screen has an auto detect feature that flips it to portrait mode when in tablet and held sideways, then back to landscape when returned to laptop. When I explored, the time interval for the refresh was the same time interval associated with the portrait/landscape switch. Some people suggested that they had resolved it by right clicking the desktop & using display properties and the Intel clone etc. This never stabilised it for me.

I did though sleuth more and found under Control Panel an app called 'Fujitsu Tablet Contols' and presumably other tablets would have something similar. When I opened this it had under the Display tab  several different profiles (all ticked) including 'Enabled docked notebook profile.' There were in essence 4 profiles corresponding to docked & tablet/laptop arrangements. There was also a spot to 'Save Current Profile." I clicked on this (while docked and the machine operating in Extended Desktop) and it saved, and the screens are now stable - from startup, reboot, refresh, screen saver, task manager etc.

So it would appear that this little applet was controlling the profiles - a trick for tablet users to watch for!

The best news though is - problem solved!!

Regards, Lloyd.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Laptops Notebooks

From novice to tech pro — start learning today.