setup OWA - Exchange 2007

I have this strange feeling I am missing something very simple, but I am struggling with getting OWA setup on our new Exchange 2007 Server. It appears that I have done all steps, but clearly I am missing something because when I am on the LAN I simply try to go to https://192.168.187.1/owa and get page can not be displayed.

Any suggestions on what I am doing wrong?
bnrtechAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
bnrtechConnect With a Mentor Author Commented:
Well folks I am back up and running. I did a complete clean install of W2003 (64bit), E2007 and all updates for both products. Once I did that everything worked perfectly. Moral of the story - SharePoint was the problem. Thanks for trying to help me!
0
 
TWBitCommented:
so you've set up and allowed for SSL?  what about just using http://<internal server name>/owa
0
 
ificuserCommented:
If you do not have certificates setup and your IIS permissions setup properly the https will not work. try the http and check, but you should defenitly enact certificates for security purposes so you can use the https configuration.
0
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

 
bnrtechAuthor Commented:
you bring up a good point. no I have not yet setup SSL. so correction in that I am using http://192.168.1871/owa. I'd like to use SSL down the road, but right now I just want to gain OWA access
0
 
maxis2cuteCommented:
0
 
TWBitCommented:
Exchange 2007's default is owa, not exchange.

can you ping the server?

is IIS running?
0
 
bnrtechAuthor Commented:
I just tried http://192.168.187.1/exchange and https://192.168.187.1/exchange. I also tried http://bnr1/exchange and https://bnr1/exchange. Still page can not be displayed.
0
 
bnrtechAuthor Commented:
yes I can ping the server

IIS appears to be running, but (dumb question) how can I confirm IIS is running?
0
 
TWBitCommented:
try going to http://192.168.187.1 to test IIS
0
 
ificuserCommented:
try owa like twbit suggested, it is the default for exchange 07, have you rebooted the server after the initial install, make sure IIS is running and that you can see the owa directory in IIS
0
 
bnrtechAuthor Commented:
when I go to http://192.168.187.1 from my workstation it says 'page can not be displayed'.

i installed sp1 for exchange07 earlier tonight and rebooted the server after the install

IIS appears to be running. my FTP site is working. I do see the owa directory in IIS and the Default Web Site is started
0
 
maxis2cuteCommented:
iff you go to iis directly is it started and if it is can you right click on it and browse, if not it may be a permission issue.

check permissions on /exchange /exchadmin /public they should all be set and integrated only  //exchweb should have basic,integrated and anonymous permissions
0
 
TWBitCommented:
how about bringing it up right from the server itself?
0
 
ificuserCommented:
Is this a cluster?
0
 
bnrtechAuthor Commented:
TWBit - I have tried the url on the server itself. no luck

ificuser - no this is not a cluster. actually this is a very flat install (test bed). it is one box running a fresh install of both w2003 server and exchange 2007

maxis2cute - I went in to IIS and tried to browse. Still unable to display. I am having trouble performng the permision check you suggest. I presume I should be doing this step from within IIS.
0
 
maxis2cuteCommented:
correct do all the steps i suggested from IIS
0
 
bnrtechAuthor Commented:
I located the permissions tab //exchweb did not have anonymous permissions, so I updated it. All others looked good. I stopped and started IIS, but no go
0
 
maxis2cuteCommented:
just for HA HA's can you  reboot?
0
 
maxis2cuteCommented:
also have you tried oma?
0
 
bnrtechAuthor Commented:
no problem on the reboot. i will do that right now.

dumb question...what is oma?
0
 
ificuserCommented:
Outlook mobile access, it is your OWA for your mobile devices, basically a text version of OWA.
0
 
maxis2cuteCommented:
oma is for mobile phones it works the same way as owa.  Also this is going to sound stupid but have you checked to see that exchange is working and you can get emails?
0
 
maxis2cuteCommented:
last two thoughs i have and then unfortunately i am at a loss is try http://127.0.0.1/owa FROM THE SERVER  and see if that works and the other

Disable "Show user friendly error" from Browser > tools > Internet Options > Advanced
Mostly it might be 404 error.

If no joy then i hope someone else can help and i will monitor the replies
0
 
bnrtechAuthor Commented:
thanks for clarification on oma. no I have not tried this out.

i have not connect with a traditional outlook setup. right now my only workstation is running Outlook 2002 (which i intend on upgradind to outllook 2007 like all other computers). I was hoping to connect with OWA just to confirm connectiivity
0
 
maxis2cuteCommented:
If exchange is not working, then unfortuantely OWA will not work.  That is the real test
0
 
bnrtechAuthor Commented:
I tried the last two thoughts and still no luck. thanks for the input!
0
 
bnrtechAuthor Commented:
ok. so tomorrow I will put my hads on Outlook 2007 cd, update the laptop and try again. Thanks and stay tuned
0
 
TWBitCommented:
Agreed that if Exchange isn't working, then obviously OWA won't work, but you can't even get to the default IIS site on the server, so I'm thinking that's where the problem is.  Are the Exchange services started? Anything abnormal in the event logs regarding IIS or exchange?  I too am out of suggestions.
0
 
LeeDerbyshireCommented:
If you go to http://192.168.187.1 from the workstation where you turned off 'Friendly HTTP Errors' (as suggested earlier), what error message is displayed now?  There should be something more than 'Page Cannot Be Displayed'.

Is the WWW Service actually started on the server (check Services)?
0
 
bnrtechAuthor Commented:
Since turning off 'Friendly HTTP errors' I get the attached error message when going to http://192.168.187.1. When I go to http://192.168.187.1/owa it returns nothing on the screen as noted in the 192.168.187.1_owa attachment.

WWW service is started on the server along with all other automatic services (noted in attachment)

I am starting to think (as noted previously in this thread) if something is wrong with IIS given that I can not open a simple default page (??).
192.168.187.1.jpg
192.168.187.1-owa.jpg
www-service.jpg
0
 
maxis2cuteCommented:
i see that you have sharepoint on this server,  that is probably taking the defaul port 80.  what port is set up for owa, please check that in iis.  go to iis, expand th ecomputer and see what other sites you have.  make sure the owa site is not stopped and then right click, go to poperties and see what the tcp port is
0
 
bnrtechAuthor Commented:
I do not see any port details under owa. I do however see port details for Sharpoint Site and Default Site. Please see attached images. Is this what you wanted me to look up?
default-web.jpg
sharepoint.jpg
0
 
bnrtechAuthor Commented:
More tidbits....I just (finally) got around to setting up Outlook 2007. When I try to connect to the Exchange Server via Outlook (while on the LAN) I am unable to connect.
0
 
bnrtechAuthor Commented:
correction - I discovered that I neglected to setup a reverse lookup zone in DNS. Once that was completed I did a nslookup on my workstation and response was good. Than I proceed to connect Outlook 2007 to Exchange 2007 and it now works. OWA still does not work, but Outlook 2007 is working.
0
 
TWBitCommented:
In your IIS console, is Default Website running?  I know from your picture that WWW Pub service is, but that doesn't mean the Default Website is running.  What is it's Home Directory values? What authentication and access control methods are you using the it? Under Default Website, you do have an virtual directory entry for OWA, right? What is it's Home Directory and authentication values?
0
 
maxis2cuteCommented:
TWbit is looking for the same information i was looking for, prior to the scrren shot yuou sent with the ports and yes that is what i needed to check,  there is a screen that will show the site in either a stop or started state

0
 
bnrtechAuthor Commented:
The default data directory is c:\inetpub\wwwroot and this directory does contain default.aspx. I believe the attached images answers the other questions posed. Please let me know if I forgot to address something
owa-virt-dir.JPG
web-site.JPG
home.JPG
access-authen.bmp
default.JPG
0
 
maxis2cuteCommented:
so from these screen shots i see both owa and exchange i do not see the little globe icon representing a web site.  but anyway, in the directory try moving default htm to the top of the list. and application pool to the default application pool. Also change the default website form an actual ip address to all unassigned, that way it will pick up all supported ip adresses in case your ip is incorect somehow.

0
 
maxis2cuteCommented:
also can i see a screen shot from the application pools
0
 
TWBitCommented:
Could you also take the same screen shot as you did with the "owa-virt-dir.jpg" but have Default Web Site selected in the left pane
0
 
TWBitCommented:
And nothing abnormal in the Event Logs?
0
 
bnrtechAuthor Commented:
I moved default.htm up, change IP to all unassigned, and stopped/started default web site. No luck.

Nothing unusual in the event logs.

Maxis2cute - check out the attached image. what specific portion of the Application Pool would you like a screen shot of?

TWBit - I believe the attacehed image also covers your requested info too.


iis-screenshot.JPG
0
 
bnrtechAuthor Commented:
BTW - I am raising the point value of this question. Looks like this one is worthy of more points.
0
 
maxis2cuteCommented:
i am lost, everything looks right.  Sorry if it was my domain i would be on the phone with Microsoft at this point.

I wish i could be of more help and i know it is one STUPID thing we are all missing so please update us with the answer you you get it.

0
 
TWBitCommented:
So there's no firewall on this machine - no TCP ports are blocked directly on the network connection's TCP properties.

Everything looks fine (from an IIS standpoint, as the problem is not owa itself (yet))
0
 
bnrtechAuthor Commented:
All good points. I plan on connecting with MS in the near future. I will post the final answer to this posting.

Thanks for trying. I do appreciate the effort.
0
 
maxis2cuteCommented:
your welcome. i wish i had the answer for you
0
 
bscnyCommented:
On the exchange server check the following.
Open IIS manager.
Web sites, default web site, exchange
properties of the Exchange
Directory Security tab
Edit Authentication.
Look where it has default domain: and Realm: if either if these fields have entries clear it out.  and click ok till you are back at the main IIS manager.
Stop and start default web site.
See if it works.
0
 
bnrtechAuthor Commented:
bscny - I checked out these settings. However, the were not enabled (actually were grayed out).

Thankfully this has been a test box so it has not been an urgent matter. I hope to call MS support this week and if so will report back to this message board.
0
 
bnrtechAuthor Commented:
I finally had a chance to open a MS support call. First they sent me to the que that handles OWA. The support guy tried somethings but had no luck. Than the OWA person confereced in someone with the IIS team. The IIS person 'kicked the tires' but no luck. Than the IIS person noticed that I had SharePoint installed on this server too, so she did some testing to see if IIS was ok when outside of SharePoint and IIS responded correctly. So than we concluded that we need a SharePoint support person on the call, but they are only available (accordint to the OWA and IIS support people) via a call back service. This was yesterday and I am waiting to hear from the SharePoint person. Stay tuned.
0
 
LeeDerbyshireCommented:
There is a well-known issue with Exchange 2003/Sharepoint coexistence described here, but I don't know how much of this still applies to E2007:

http://office.microsoft.com/en-gb/winsharepointadmin/HA011607771033.aspx
0
 
maxis2cuteCommented:
this is unreal.  I would uninstall and reinstall, or is there another serve you can add owa to and not use one that already has IIS?

0
 
LeeDerbyshireCommented:
OWA can only exist as a component of an E2007 CAS server.  Unfortunately, you can't put it on a server by itself.
0
 
bnrtechAuthor Commented:
this one definitely falls in the 'unbelievable' category.

So after mutiple conversations with MS (with support from OWA, IIS and SharePoint team) I have gotten absolutely no where. Clearly the problem has more to do with SharePoint playing nice with other apps, but no one can identify and/or resolve the actual problem.

So after wasting too much of my personal time on this matter I have decided to do a fresh install on this server and only put E2007 back on this box. Than setup a seperate box to host SharePoint and SQL. I can tell you that there was a collective sigh of relief by MS when I decided to scrap the current setup and start over :)
0
 
maxis2cuteCommented:
That is ridiculous.  Let me know the outcome.

0
 
LeeDerbyshireCommented:
I think they assume that unless you have SBS, then everyone is happy to have a single dedicated server for each server application.  One for Exchange, one for SQL, one for SharePoint, etc.  It doesn't occur to them that small companies don't all have an endless supply of money, and that we would want to sometimes combine server applications.
0
 
bnrtechAuthor Commented:
You bring up a very interesting point.

I would also add that in particular the SharePoint group was very much from the school of 'pull Sharepoint and put it on its own server'. Plus the SharePoint group was extremely difficult to connect with (they do 'call back' support) and seemed a little unfamilar with MS technology outside of SharePoint.

The OWA and IIS people were pretty helpful. I get this strange feeling had I not installed SharePoint on this server this would have never been an issues.

Stay tuned and I will update everyone when I complete the clean re-install
0
 
LeeDerbyshireCommented:
I think SharePoint does things to IIS that pretty much mess it up for anything else.
0
All Courses

From novice to tech pro — start learning today.