Can Joomla1.5 really run in window xp

Hi Everybody,

I was trying to install Joomla1.5 to run in my notebook window xp home edition.
I have installed apache2.2, mysql 4.1.22, php 5.2.4, mysql administrator and phymyadmin successfully.
Then I installed joomla1.5 and when the click the Admin button to go to Administrator screen, what I got was

Strict Standards: Non-static method JLoader::import() should not be called statically in C:\public_html\libraries\joomla\import.php on line 34

Strict Standards: Non-static method JLoader::register() should not be called statically in C:\public_html\libraries\loader.php on line 68

Strict Standards: Non-static method JLoader::import() should not be called statically in C:\public_html\libraries\joomla\import.php on line 37

Strict Standards: Non-static method JLoader::register() should not be called statically in C:\public_html\libraries\loader.php on line 68

Strict Standards: Non-static method JLoader::load() should not be called statically in C:\public_html\libraries\loader.php on line 155

Strict Standards: Non-static method JLoader::register() should not be called statically in C:\public_html\libraries\loader.php on line 132

Strict Standards: Non-static method JRequest::clean() should not be called statically in C:\public_html\libraries\joomla\import.php on line 38

Strict Standards: Non-static method JRequest::_cleanArray() should not be called statically in C:\public_html\libraries\joomla\environment\request.php on line 422

Strict Standards: Non-static method JRequest::_cleanArray() should not be called statically in C:\public_html\libraries\joomla\environment\request.php on line 423

Strict Standards: Non-static method JRequest::_cleanArray() should not be called statically in C:\public_html\libraries\joomla\environment\request.php on line 424

Strict Standards: Non-static method JRequest::_cleanArray() should not be called statically in C:\public_html\libraries\joomla\environment\request.php on line 425

Strict Standards: Non-static method JRequest::_cleanArray() should not be called statically in C:\public_html\libraries\joomla\environment\request.php on line 426

Strict Standards: Non-static method JRequest::_cleanArray() should not be called statically in C:\public_html\libraries\joomla\environment\request.php on line 427

Strict Standards: Non-static method JLoader::import() should not be called statically in C:\public_html\libraries\joomla\import.php on line 40

Strict Standards: Non-static method JLoader::register() should not be called statically in C:\public_html\libraries\loader.php on line 68

Strict Standards: Non-static method JLoader::import() should not be called statically in C:\public_html\libraries\joomla\import.php on line 43

Strict Standards: Non-static method JLoader::register() should not be called statically in C:\public_html\libraries\loader.php on line 68

and much more...

Does anyone know how to solve this problem or can Joomla1.5 really run?
Anyone knows if it can run in window xp or any solution for the problem?
ricjavaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gxp071Commented:
I have installed joomla 1.0.XX and 1.5 on at least 10 windows machines in the last 6mnths on both xp and vista and never had a problem.  To be specific its always been  XP pro SP2 or XP MCE 2005 but there should be no real difference.

I have had problems with PHP and apache installed separately on windows before but that wasn't specific to joomla.  

Ive alway got round that by just installing XAMPP a package by Apachefriends which installs apache, php, mysql all in one go and pre connected...  Saves a lot of time and you know you platform its configured correctly before you start installing any applications.

If I had to bet on it though i would say you either there is something in your php.ini that is upsetting joomla or that there is something in php 5.2.4 that causing problems.

I have the latest build of joomla on this XP pro SP2 machine, running PHP 5.2.0, Apache/2.2.3 and mysql 5.0.27-community-nt

Hope that helps point you in the right direction :D
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ricjavaAuthor Commented:
So for XAMPP, after u installed it......no configuration for XAMPP and can install joomla right away?
0
gxp071Commented:
yep, the only config xampp needs is setting the passwords for sql and the xampp web control panel..  ... This is optional but recommended for security

then login into phpMyAdmin which XAMPP also installs as part of its web panel, and create a db for joomla....

copy the joomla files to the htdocs folder, and away you go.. has worked every time for me.
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

ricjavaAuthor Commented:
My home internet connection is too slow....it doesn't matter isn't it as the joomla runs on my notebook with xampp, does it?
0
gxp071Commented:
joomla should run very quickly locally and should have nothing to do with your Internet connection.  Any xampp site on you local computer will be available whether or not your connected to the Internet.

If you asking whether hosting a site at home will be effected by hosting it on your notebook, as long as your notebook is of a reasonable spec and isn't tasked with too many other tasks... then it will be fine, your main bottle neck will be your Internet connection.  Even if you have highspeed broadband connection  e.g. 8mb ADSL pretty standard for here in the uk, you upload rate will only be 256k - 512k Max  unless you pay a fortune for SDSL which has the same up and down bandwidth. e.g. 8meg up 8 down.

having said that we host an Intranet site from our office using an 8mb ADSL connection and its fine for the 1 or 2 external / Internet hits it gets a day.  However the moment anybody in the office uploads a large email attachment or if anybody sharing you connection fires up a per to per client like torrents then you site will be really sluggish from the Internet side...

Hope that helps
0
ricjavaAuthor Commented:
Thanks for comment..
Anyway, I  just uninstalled apache,  mysql, php, phpmyadmin from my notebook.
After that, I installed xampp successfully.
However, when i run the xampp, and then click the Admin of Mysql, a screen appear to prompt me to enter Username and password. After I clicked OK, an error message kept appearing.  The message is

Access violation at address 10002593 in module 'LIBMYSQL.dll'. Read of address 00000000

Please help me...
0
gxp071Commented:
Hi

never had the problem your experiencing now but found the solution on a forum.  sorry its half in german but there seems to be a solution that everyone agrees works.

http://www.apachefriends.org/f/viewtopic.php?t=27780&sid=ef9da576724ae6658fa380e46cf59046

but it seems its a problem where MySQL's root password is not what XAMPP thinks it is. i.e. when XAMPP is first installed its username: 'root' with a blank password.  all i can guess is that something was left over form your previous MySQL install that had changed the password.

They suggest using the winmysqladmin to set the password back to nothing and then user xampp's interface to set as you would normally,

"
I posted this on another thread, but repeating it here. Sorry, I don't know German at all, so I'm replying in English. Smile

I think I've found the solution. Ignore the dialog box popping up every 10s or so, and open up winmysqladmin. There's a tab 'my.ini Setup'. Go there.

You'll find the contents of the my.ini file in a textarea and at the bottom it indicates:

user=root
password=password

Now this is the first time I've installed XAMPP, so I don't know what it did before but I noticed MySQL installs with a default of 'root' and NO password. You can test this by removing the password so that your entries now say:

user=root
password=

And then click the Save Modifications button. This *should* stop the popups. If it does you've got 2 options:

1. Leave it like that and continue with root and no password (which I think is bad)
2. Leave winMySQLAdmin like it is, and rather go and change MySQL to have root and password of 'password'. At any rate there should be SOME password.
"
0
ricjavaAuthor Commented:
Ok....the error message has now stopped appearing after I set the password to nothing
password=

But now how can I start to create a database for joomla?
0
ricjavaAuthor Commented:
Anyway, now I can't start mysql.

It is saying
Busy...
ERROR: Mysql service not started [-1]
0
wonkotsaneCommented:
I am running a local install of Joomla 1.5 on my laptop with XP Home.  I'm using Abyss web server because it's free, reliable and their website has pre-configured patches for things like PHP.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Applications

From novice to tech pro — start learning today.