Cisco SSL VPN - NAT problems

I have configured a SSL VPN on a new ASA5505 and followed the cisco configuration example at http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a008071c428.shtml
Of particular note is the fact that the IP range for the IP Pool is a valid IP address range on the internal network. This different to how IPSEC VPNs are configured. Also the example has no 'nat 0' rule which I assume is because the ip range is internal.

The problem I am having is that I am getting errors like the following when the SSL VPN is established which points to a NAT issue but following the Cisco example this should never happen.
  No translation group found for udp src outside:10.0.110.100/1467 dst inside:10.0.1.9/53

Do I have a mistake in my configuration causing this?
Or is the cisco example wrong/incomplete and I should have a nat 0 rule?
If so should I be using an internal IP address pool or should it be external like IPSEC client VPNs?


The nat 0 acl I have in the config is just a leftover from when I had a ipsec vpn configured.
ASA Version 7.2(3)
!
hostname asa5505
domain-name linguaphone-intranet.co.uk
enable password XXXXXXXXXXXXXXXX encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.0.0.3 255.255.0.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address xxx.xxx.60.164 255.255.255.248
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd XXXXXXXXXXXXXXXX encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name linguaphone-intranet.co.uk
access-list vpnstaff_splitTunnelAcl standard permit 10.0.0.0 255.255.0.0
access-list inside_nat0_outbound extended permit ip 10.0.0.0 255.255.0.0 192.168.110.0 255.255.255.128
access-list inside_access_in extended permit tcp any interface inside eq ssh
access-list inside_access_in extended permit ip host 10.0.1.9 any
access-list inside_access_in extended permit ip host 10.0.251.1 any
access-list inside_access_in extended deny ip any any
access-list staffACL extended permit ip any any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool staffssl 10.0.110.100-10.0.110.200 mask 255.255.0.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.60.161 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
aaa authentication ssh console LOCAL
http server enable
http 10.0.0.0 255.255.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-AES-256-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
crypto isakmp ipsec-over-tcp port 10000
no vpn-addr-assign aaa
no vpn-addr-assign dhcp
telnet timeout 5
ssh 10.0.0.0 255.255.0.0 inside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
 
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
ntp authenticate
ntp server 10.0.1.9 source inside prefer
tftp-server inside 10.0.1.9 asa5505-confg
webvpn
 enable outside
 svc image disk0:/sslclient-win-1.1.0.154.pkg 1
 svc enable
 tunnel-group-list enable
group-policy SSLstaff internal
group-policy SSLstaff attributes
 wins-server value 10.0.1.5
 dns-server value 10.0.1.9
 vpn-idle-timeout 15
 vpn-tunnel-protocol IPSec l2tp-ipsec webvpn
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value vpnstaff_splitTunnelAcl
 webvpn
  svc enable
  svc keep-installer installed
  svc rekey time 30
  svc rekey method ssl
username tdurell password XXXXXXXXXXXXXXX encrypted
username tdurell attributes
 vpn-group-policy SSLstaff
username gblades password XXXXXXXXXXXXX encrypted privilege 15
username gblades attributes
 vpn-group-policy SSLstaff
tunnel-group SSLstaff type webvpn
tunnel-group SSLstaff general-attributes
 address-pool staffssl
 default-group-policy SSLstaff
tunnel-group SSLstaff webvpn-attributes
 hic-fail-group-policy SSLstaff
 nbns-server 10.0.1.5 timeout 2 retry 2
 group-alias Staff enable
prompt hostname context
Cryptochecksum:97af2a146c4fd74612fcc8e1019047eb
: end

Open in new window

LVL 36
grbladesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

batry_boyCommented:
Hi grblades,

I would try using an address pool that is not part of your internal network range, like in IPSEC VPN's.  I've been using SSL VPN's on the ASA's for a while and have not had any translation problems when using non-internal VPN pools.  That would be an easy thing to try, too.  :)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
grbladesAuthor Commented:
Ok I think I will try adding a nat0 rule today and giving it a test tonight. I would really rather not use an external ip address pool as the ASA is on a backup SDSL line and so is not the default route.
0
batry_boyCommented:
Do you have a L3 device on your internal network to add a static route to for the VPN client pool such that it would point to the ASA inside interface?
0
Get Certified for a Job in Cybersecurity

Want an exciting career in an emerging field? Earn your MS in Cybersecurity and get certified in ethical hacking or computer forensic investigation. WGU’s MSCSIA degree program was designed to meet the most recent U.S. Department of Homeland Security (DHS) and NSA guidelines.  

grbladesAuthor Commented:
No we dont. Its not a major problem as it is really just a domain controller (windows) and the main file server (linux) which people will be connecting to. I'll just add a static route to them if I need to.

Should be able to do the testing today or next week. I have to take remote control of a home machine and then try from there while at work so I can check the logs while I do it. It makes testing a bit of a pain :)
0
grbladesAuthor Commented:
Adding a nat0 line for the internal IPs we were using has fixed the problem. No idea why it want shown on the cisco example.
0
DouRiXCommented:
I have the same problem of communication to LAN. Although, the nat0 setup is already there (details here attached):

access-list 101 extended permit ip 192.168.0.0 255.255.255.0 10.0.11.0 255.255.255.0
nat (inside) 0 access-list 101

SSL VPN details:
- LAN: 192.168.0.0/24
- SSL VPN pool: 10.0.11.0/24
- Tunnel Group: Test-WebVPNGroup

My environment:
- Cisco ASA 5520 v. 7.2(2)19,
- ASDM v. 5.2(2)
- SVC client: sslclient-win-1.1.4.179.pkg
- Desktop: Win XP

any idea?
asa1-vpn-ssl-config.txt
0
DouRiXCommented:
i finally resolved the problem by adding a reverse of the acl for nat0 (ip pool -> LAN)

access-list 101 extended permit ip 10.0.11.0 255.255.255.0 192.168.0.0 255.255.255.0

in case it may help someone later

thanks,
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.