Binding problems in Mac OSX

Hi.

I have a Windows 2003 environment... in my lan, i have two MacOSx boxes (one with Leopard, the other with the previous OS... I think is Tiger).

Until yesterday, all my Macs were working flawless, but for some unknown reason, the Tiger Mac lost the binding with Active Directory yesterday and all connection with my server (Server01).

If i try to connect to a Server01 share (smb://server01/share), Mac returns me an error telling me that "the login and password were incorrect", but the connection never asks me for any login information... i tried erasing all the entries in my keychain, but up to now, it has been useless; if i try to access to my server using Finder/Network, my server doesn't appear.

Now, when i try to bind this computer to Active Directory (my active directory name is server01.mydomain.com), the process freezes in the 5th step and after a lot of time, it tells me that "an unknown error was detected".

If I ping my server, it answers me, so i think it's not a network problem.

What can i do?

Thank you

(By the way, i'm not a Mac OS expert, so if you can answer me a procedure step by step, it would be appreciated)
kalvilloAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

strungCommented:
0
tgunnrCommented:
Known problem on the Leopard server, only solution right now is to stop and start the AFP/SMB file server. Fixed in 10.5.2 I am told.
0
strungCommented:
True, but Kalvillo says his problem is binding a Tiger Mac to a Windows 2003 server, unless I misread the initial post.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

DarylxCommented:
Check the system time on the OSX box.  If it is more than 5 mins out from the domain controller, you'll lose access.
0
kalvilloAuthor Commented:
I checked the system time... that's not the problem.

strung> apparently, your solution is what i need, but the procedure that you shared with me is not very clear... do you have a more specific procedure?
0
strungCommented:
I don't, I am afraid.  
0
heteronymousCommented:
On your Mac client machine, try setting aside
/etc/krb5.conf
/Library/Preferences/edu.mit.Kerberos
and if it exists,  
/etc/krb5.keytab
and if it exists,
/Users/<yourusernamehere>/Library/Preferences/edu.mit.Kerberos

and then re-binding the client.

You might also want to read
http://web.mit.edu/macdev/KfM/Common/Documentation/preferences-osx.html
0
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
Before you delete your Kerberos preferences have your tried this...

go in to /System/Library/Core Services ad launch the Kerberos Application.  

Click on new and acquire a new kerberos ticket for your AD domain.
0
heteronymousCommented:
A good thing to try, but my point was to *set aside* those files not delete them.
A bad file or one with incorrect info could still prevent getting a new/proper ticket, so the step of putting aside the files may still be necessary.
0
kalvilloAuthor Commented:
i'd tried everything.. i even formatted the Mac box and i'm having the same binding problems... i guess the problem is on the server side, but i don't know what to fix there, because all the other PCs (i even have one Mac OS X Leopard box working without an issue).

What i need to do?, i hope you can help me
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DarylxCommented:
It's more likely to be a Tiger problem than a server problem.   Tiger broke a lot of things that worked perfectly well in Panther (10.3).  If no one can come up with a fix, one solution could be to put Panther on it.
0
heteronymousCommented:
Well, Tiger fixed alot of things that never worked right or easily or reliably in Panther ;)
*Especially* Active Directory binding. In a big way.

First, try deleting the computer account for the Mac OS X Client machine (and/or the server if you can't bind it still), then unbind via the Directory Access tool (yes, still "unbind"), and then rebind via that tool.

On the client, you might also want to try (in the Terminal):
dscacheutil -flushcache

and try rebinding.


Also, DNS is critical here. If you've done a fresh install of 10.4 (with all updates) and can't bind a client to your AD, then it's really quite probably *not* a Mac OS X issue.

Are you putting anything in the "search domain" field in System Preferences > Network > Built-In Ethernet (or, whatever name is assigned to the LAN port) ?

What's the name of the server you're trying to bind to ?
Can you resolve its FQDN from Mac OS X via: dig fqdn.youradserver.com  
and
dig -x ip.address.ofserver


If clients are also bound to your OD Master (OS X Server) you might want to see
http://docs.info.apple.com/article.html?artnum=300765 
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple OS

From novice to tech pro — start learning today.