Mapping LPT1 to IP printer: System 66 error

I'm using an old DOS program that gives the option of printing to LPT1, 2 or 3.  My computer is running Windows XP and has no physical LPT ports.  I would like to remap LPT1 to print to an HP LaserJet 4200 printer using HP jetdirect 680n, which is accessed through a Linksys Wireless B router.  The printer is currently being used by two different computers (both Apple and IBM systems), but is not set up as a shared printer on my computer.  I am able to ping the printer using its IP address.  I am using Norton Antivirus 2007.

I understand that remapping can be accomplished using the "net use" command in the DOS window, but I get the error message "System error 66 has occurred.  The network resource type is not correct."  The syntax I used is
net use lpt2 \\mycomputername\printername /Persistent:yes
I've tried the command in various ways using lpt1, 2 and 3, and dropping the persistent command, but still get the same error.  Any suggestions?
JVauditorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

michkoCommented:
Close the lpt1 connection first.

net use lpt1 /delete

After that processes, then try your net use command again.  Your syntax looks fine.
0
JVauditorAuthor Commented:
I tried

net use lpt1 /delete

I got the message "The network connection could not be found"
0
michkoCommented:
Create it as a shared printer, then do the net use command.  This link gives a good explanation of printing to an IP printer through lpt1:
http://members.shaw.ca/bsanders/printfromdos.htm
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JVauditorAuthor Commented:
YES!  IT WORKED!!  Thank you so much!  I am now able to print from my DOS program to my IP printer.
My problems were twofold:  
  1) The printer was not set to be shared, and
  2) I was using the computer description rather than the full computer name in the net use command.

michko pointed me in the right direction, and with a little experimentation with the net command, I finally put the pieces together.
0
michkoCommented:
You are very welcome.  This reaction is one of the biggest reasons I enjoy EE so much.  Glad I was able to help.

michko
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.