I have thousands of emails queued outbound to a Domain bankname.com. Nothing in message tracking.

I have thousands of emails queued outbound all from an email address of oasisservice@bankname.com to an email address called admin@bankname.com. They are not coming in from the Internet as far as I can see. The subject indicates hidden. I don't know where they are coming from. If you check, you will see that the Domain bankname.com does not have an MX record associated with it. Wierdess thing is, when I do message tracking on these addresses in Exchange, I see nothing!! I tried to create a Sender Filter blocking the sender email address and then configured the smtp virtual server accordingly but they are still queueing up. I did a virus scan and found nothing. This has been going on for weeks but there were never more than a dozen message queued up and I did not have time to investigate it. Now, its thousands. Why are they not showing up in message tracking?
Who is Participating?
isaman07Connect With a Mentor Commented:
Have you tried looking at the headers of the email? Is there anything in it?
A machine or an application on your LAN is generating those emails. I would stop IS and SMTP, delete all the emails in the queue, add the domain bankname.com to the blacklist and restart exchange.
Michael WorshamInfrastructure / Solutions ArchitectCommented:
One thing you might want to consider setting up on your Exchange server is to look at the RBL list and prevent spam like this from being passed through your Exchange server environment. IMF is only one part of the Exchange that needs to be configured.


Another possibility could be that you have a PC somewhere on your network that has been converted into a Bot, thus trying to send the messages. I recommend running an anti-virus/anti-spyware application on all PCs and Servers connected to the network.
osiexchangeAuthor Commented:
I doubt its a virus. I have attached a screen shot of one of the messages. Looks perfectly innocent. I don't understand why these are not showing up in message tracking. I do have it enabled. I tried to use message filtering to block the sender address which is always the same but they are still accumulating. I configured the Global settings and added the sender address to the Sender Address block list and configured the SMTP virtual server to apply the filter, then restarted it. They have slowed down, but not stopped. Any explanation as to why they are not showing up in message tracking?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.