How to suppress whitespace in a drilldown for textboxes that have a filter applied

I'm trying to suppress whitespace in a drilldown for textboxes that have a filter applied.  

I have a matrix report that is showing whitespace in a drilldown because I am supressing duplicates. Based on what I read in other forums, if I set the ToggleItem to Len(FieldName)=0 that should supress the whitespace, right?

I can see that I have a field in the toggleitem called: Firstname. If I put the value Len(Firstname)=0 in the toggleitem property, then I get the error: The textbox 'textbox21' has Len(Firstname)=0' as a toggle item. Toggle items must be text boxes that share the same scope as the hidden item. I think the code 'Len' is throwing it off.

If I put the value "Firstname" in the toggleitem property, then it doesn't return the error, so I know that firstname is a valid value for toggleitem, but setting the value to firstname doesn't suppress anything.

If someone can tell me how to supress a textbox based on a value, then this may get rid of the whitespace I'm trying to suppress.  Any ideas?  Thanks...
rcearleyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JimFiveCommented:
What about FirstName = ''
0
rcearleyAuthor Commented:
I just tried it.  It causes the same error.  Thanks...
0
rcearleyAuthor Commented:
I figured out the answer to my own question.  ToggleItem has nothing to do with the answer.

If you have "suppress duplicates turned on, then to suppress whitespace, you have to set hidden property of the row in the table and hidden property of the textbox to the following:

=Previous(Fields!Firstname.Value) = Fields!Firstname.Value

What this does is that for the first record, the expression returns false.  since the hidden value is false on the first record, that means that hidden="false", thus, don't hide the first record.

When the report evaulates the 2nd and 3rd records, which are suppressed because of the suppress duplicates setting, the expression will evaluate to hidden="true", which means, yes, hide duplicates.  

The result is that the report will not show blank spaces when you have the setting suppress duplicates turned on.
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

rcearleyAuthor Commented:
Now that I answered my own question, I'm not sure how to close this question out...  
0
JimFiveCommented:
I believe that you post a message in the Community Support Forum with the CustomerID asking to close the question.
0
rcearleyAuthor Commented:
Ok, Thanks
0
Computer101Commented:
PAQed with points refunded (250)

Computer101
EE Admin
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2005

From novice to tech pro — start learning today.