?
Solved

Task Manager grayed out.

Posted on 2008-01-30
7
Medium Priority
?
8,200 Views
Last Modified: 2011-10-19
I have a computer that had a virus that disabled the use of task manager under a certain profile but it still works under everyone elses profile. I have run out of ideas on how to re-enable it for this person. I have tried reseting all local polices back to default but that didnt' seem to fix the problem. Any suggestions?
0
Comment
Question by:Rob Siddell
7 Comments
 
LVL 59

Accepted Solution

by:
LeeTutor earned 2000 total points
ID: 20779588
This web page may be of help:

http://windowsxp.mvps.org/Taskmanager_error.htm
0
 
LVL 15

Expert Comment

by:Joseph Hornsey
ID: 20779592
Rename the user's profile and then have them log on again to create a new one.  Then, copy their Favorites and other stuff back from the old profile.  What do you think?

<-=+=->
0
 
LVL 11

Expert Comment

by:theProfessa
ID: 20779606
You can find a link to Task Manager Reset here:
http://windowsxp.mvps.org/
0
[Webinar] Improve your customer journey

A positive customer journey is important in attracting and retaining business. To improve this experience, you can use Google Maps APIs to increase checkout conversions, boost user engagement, and optimize order fulfillment. Learn how in this webinar presented by Dito.

 
LVL 2

Expert Comment

by:JohnnyIT
ID: 20779621
First make sure that the group policy is not set to disable task manager.  Then check the registry key.  See below how to do both.

From this Site: http://www.windowsnetworking.com/kbase/WindowsTips/WindowsXP/UserTips/Customization/EnableDisableTaskManagerinWindowsXPHomePro.html


Hive: HKEY_CURRENT_USER
Key: Software\Microsoft\Windows\CurrentVersion\Policies\System
Name: DisableTaskMgr
Type: REG_DWORD
Value: 1=Enablethis key, that is DISABLE TaskManager
Value: 0=Disablethis key, that is Don't Disable, Enable TaskManager

As part of the enhanced management available in Windows 2000 and Windows XP, rather than risking a registry change, as an administrator you can enable or disable Windows 2000 Pro or Windows XP Pro's TaskManager using Group Policy Editor. This can be applied to the local policy. Note: if you are trying to override your organizations group policy, you can't. As soon as you re-authenticate to the domain, the domain or OU Group Policy will rewrite the registry setting. But if the TaskManager was accidently disabled or you need to control this item for a set of standalone boxes this is for you:

Click Start
Click Run
Enter gpedit.msc in the Open box and click OK
In the Group Policy settings window
Select User Configuration
Select Administrative Templates
Select System
Select Ctrl+Alt+Delete options
Select Remove Task Manager
Double-click the Remove Task Manager option

And as I mentioned above, since the policy is Remove Task Manager, by disabling the policy, you are enabling the Task Manager.

Got XP Home - use the registry edit.

0
 
LVL 27

Expert Comment

by:David-Howard
ID: 20779620
Here are a few links that may help.
http://windowsxp.mvps.org/Taskmanager_error.htm
http://articles.techrepublic.com.com/5100-1035_11-1054840.html?tag=viewfull
http://www.softwaretipsandtricks.com/forum/windows-xp/7568-buttons-task-manager-all-greyed-out.html
If the reset policies don't work you may try recreating the users profile.
To do this, log on as yourself (Admin rights needed) and rename the users profile. I usually rename it to: Username_old.
Then, log on as the affected user and test.
If it works, open the old profile and copy the required data, desktop settings, IE Favorites, etc. to the newly created profile.
David
0
 
LVL 1

Expert Comment

by:3cc3ntric
ID: 20779660
Hi there,

Try this

it's a txt file, rename to .reg and it should help.

Hope this helps

Oh and the content of the file is as follows

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"DisableTaskMgr"=dword:00000000

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects\LocalUser\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"DisableTaskMgr"=dword:00000000
"**del.DisableTaskMgr"=" "

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system\]
"DisableTaskMgr"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
"DisableCAD"=dword:00000000

Enable-Taskmanager.txt
0
 
LVL 7

Author Closing Comment

by:Rob Siddell
ID: 31426475
Worked like a charm! thanks. Just had to delete out that registry key.
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We have adopted the strategy to use Computers in Student Labs as the bulletin boards. The same target can be achieved by using a Login Notice feature in Group policy but it’s not as attractive as graphical wallpapers with message which grabs the att…
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
How can you see what you are working on when you want to see it while you to save a copy? Add a "Save As" icon to the Quick Access Toolbar, or QAT. That way, when you save a copy of a query, form, report, or other object you are modifying, you…
Suggested Courses

589 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question