Why am I getting this stop error "Stop:c0000145 (application error)

I'm working on a older p3 Dell laptop that was running windows 2000 just fine, but the owner wanted to switch to xp pro. During the installation, at the part that says "setup checking disks" I get this error "Stop:c0000145(application error). The application failed to initialize properly (0x0000006). Click on ok to terminate the application." I tried several times bur got the same error. Unbutu live worked fine.This laptop was bought from the used pc store at Pratt & Whitney, (airplane engine builder). Could the hard drive be locked or something? Thanks for your help  Ed
Who is Participating?
johnb6767Connect With a Mentor Commented:
Might be worth a shot..... I have had errors before from backup copies.....
Are you upgrading or new install?

I would look at wiping the drive with DBan, and then install from scratch (backup the disk first...)

Darik's Boot and Nuke (Hard Drive Disk Wipe)

Would also be worth running through some HW diags....

UBCD has Memtest on it.... Let it run for about an hour or two...

Ultimate Boot CD - Overview

I would even double check the HDD with the Manufacturer's util on the UBCD as well....

And a original, or burned CD?
Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

EtrixAuthor Commented:
This is a clean install and I formated with the xp disk but I'll try DBan tomorrow (the laptop is at work). The disk is a back up of my disk that I have here at home. Should I use the original disk?  Thanks  Ed
Pétur Ingi EgilssonSoftware Engineer -- ConsultantCommented:
Even if the harddrive is OK you should buy a new one.
Old disk will fail soon.
EtrixAuthor Commented:
johnb6767, you got it. I tried the original cd and the install went great. I read Dell & Compaq (probably others) somehow check for original cd's.
I also tried an older P2 Dell laptop I had lying around, just to check and see if it happened again & it did. At the same place "setup checking disk" the same thing happened, error.                                      Thanks for your time johnb6767    Ed
No problem.

Sometimes it is just a bad .iso....

I had a brand new copy of a Vista DVD, went to install , and had a similar issue...

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.