Permissions errors after adding dll to gac and changing to full trust

I am a novice to programming in general, but I am adding a dll to my application that allows us to access our database (raiser's edge), I was getting permissions error when trying to debug, I created a strong name for the dll and added it to the gac, then added the dll to my references and I still got the same error, so I went in a changed the trust level of the dll to full trust. I went into my application and tried again. Still getting the same error. I tried refreshing the Assemblies Cache and restarting my machine thinking that maybe the settings did apply yet. I still keep getting the same error.

Does anyone have any idea what I did wrong?
aogusafaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

aogusafaAuthor Commented:
I think I found it, I was able to adjust my zone Security for our intranet and the error went away
Is this just a temporary fix, or should this fix my problem if I try to use this dll on another application?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Development

From novice to tech pro — start learning today.