Ref field in Word header

Ok,
The boss would like me to make a change to our Word templates
Page one has a createddate field right in the top center of page one, not in the header
On second page he would like the header to include that dat in it as well.

How do I reference header on page two to use that created date shown on page one?
LVL 1
jsarinanaAsked:
Who is Participating?
 
GrahamSkanConnect With a Mentor RetiredCommented:
To appear on page 2 only requires some manipulation of Page Setup and/or sections. Exactly how depends on the size of the document and your precise requirements.

As a minimum, in File/Page Setup..., Layout tab, tick Different first page.

The simplest way to get the same date is to put another CreateDate field in the second page header. Otherwise you could bookmark the CreateDate field on the first page and then put the Ref field in the second page header, referring to the bookmark.
0
 
jsarinanaAuthor Commented:
Thanks Graham
Our proplem is for some unknown reason the first page works fine but our header on the second page
using Createdate always refers back to when the tempale was last edit not the doc itself.
If I have a createdate on page one how do I bookmark it? is it a field?

Sorry I'm not a Word person
0
 
GrahamSkanConnect With a Mentor RetiredCommented:
CreateDate is a field. It should display the same date that is on the Statistics tab of the Properties dialogue (from File menu).

A Word field contains instructions to compute something to display other than the entered text. The display remains there until the computation is done again. After the field is created, there are few events that will cause the field to update.
Printing will force fields to update if the Update fields option on the Print tab of the Options dialogue (from Tools menu).

All the fields in the selection can be updated with the F9 key, and it is possible to write a VBA macro to update fields.

In your template, both CreateDate fields will be the same, but only the one in the body text is getting updated when a new document is created. Changing to another field type will not solve the problem.

If it is only mandatory the the date be correct on printed documents, make sure that the option is set. Otherwise, you have the option of switch to the header, select the text and press F9.

You could have some VBA in the ThisDocument module of your template. The code is in the snippet:

 



Private Sub Document_New()
    Dim sty As Range
    For Each sty In ActiveDocument.StoryRanges
        sty.Fields.Update
    Next sty
End Sub

Open in new window

0
 
jsarinanaAuthor Commented:
thanks
0
All Courses

From novice to tech pro — start learning today.