Deleting a stubborn file - Modifying File Allocation Table

My "D" drive is a FAT32 one. I have a file there, under D:\Del\ folder, named "000" (without extensions). The size is shown as 14 kilobytes in the "details" view of the folder, but when you right click the file itself, it shows 0 kilobytes! There is no creation/modification/access date, and worst of all "it can't be deleted"!

I tired safe mode, tried MoveOnBoot and Unlocker, tried CHKDSK (as well as the graphical checkdisk tool which requires the system to restart), but no avail. The only idea I have is to directly touch the File Allocation Table and remove the file from there.

Is that possible? With which software (preferably freeware)? Does WinHex (http://www.winhex.com/disk-editor.html) do that, and if yes, what should I edit exactly?

OS: Windows XP SP2 Pro
LVL 14
hujiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jfolcikCommented:
Try sharing the directory out and browsing to it over the network, then deleting it from there using the command line.  Process explorer might say if it is locked by a program.
0
hujiAuthor Commented:
It had nothing to do with locked processes indeed. I solved it a few seconds ago. When I opened WinHex it gave me a warning about an unexpected directory structure on an offset. I went there, and noticed that it is where the file "000" was defined. By comparing that to the currently deleted files of the same directory, I figured that I should change the first byte to "E5" to remove the file. I did so, and now the file is gon!

Thanks anyways,

Huji
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hujiAuthor Commented:
LeeTutor,

I asked that right away! After all, I have been a Cleanup Volunteer here for a long time (currently on a long term vacation) and know how EE works  ;p

Thanks anyways!

Huji
0
AnnieModCommented:
PAQ'd and 115 points refunded

AnnieMod
Cleanup Admin
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.