Openser installation problem with postgres

Using Openser on Redhat ES4.0.
Postgres 8.1.3 was installed post Linux install (put into /usr/local/pgsql).
Following openser installation, we have error when starting openser:
I get "ERROR:core:sr_load_module: could not open module </usr/local/lib/openser/modules/postgres.so>: /usr/local/lib/openser/modules/postgres.so: undefined symbol: PQescapeByteaConn"
My postgres installation is done outside of the distro installation. I do not see an option to help the configure / make process find the actual pqxx lib and the pgsql install locations...I assume it found them, but maybe not. openserdbctl worked perfectly.
JerryNortonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

http:// thevpn.guruCommented:
I get "ERROR:core:sr_load_module: could not open module </usr/local/lib/openser/modules/postgres.so>: /usr/local/lib/openser/modules/postgres.so:

you have compiled OpenSer without postgres support..open the MakeFile you will find an exlude_modules option delete the postgres option from that option then make all then make install and try again.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JerryNortonAuthor Commented:
Hi,
That was a likely culprit, but I actually did change the Makefile and compile (it says to do this in the instructions, so I wasn't being all that clever).
In /usr/local/lib/modules there is a postgres.so
If I do: strings postgres.so | grep PQ I see
PQescapeByteaConn
and
%s [%d] ERROR:postgres:%s: PQescapeBytea failed
(along with the other usual suspects).

0
gheistCommented:
The problem is "Postgres 8.1.3 was installed post Linux install (put into /usr/local/pgsql)"
Install redhat's rpm and every ./configure will catch up.
0
JerryNortonAuthor Commented:
Thanks everyone. Problem found to be openser needed the most recent libpq.so from postgres, found in 8.2.x. Installing from rpm wouldn't help (redhat behind on that front). Also, am I the only person that has systems with interdependencies? everyone seems to be willing to upgrade without worrying about compatibility ... regression testing ... etc.

Am splitting the points but if anyone reads this, note that the solution is not quite here. As i could not fiind anywhere on openser's site that includes a required revision level for any module.
0
JerryNortonAuthor Commented:
Thanks for trying
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
PostgreSQL

From novice to tech pro — start learning today.