DW CS3 Broke - seems to connect - gives Toggle Passive FTP on all sites

This Vista Ultimate computer with Dreamweaver CS3 has worked for months. On Thursday (1/24) I started on a new UNIX hosted site. I had to turn off FTP Performance Optimization (FPO) in Server compatibility to connect.   After that change I could only connect to some UNIX sites with FPO turned off.  I could not connect any Windows sites. After 3 reinstalls (2 per Adobe Support) and the addition of Microsofts cleanup tool (msicuu2) and Adobes tool (wincs3clean) neither CS2 or CS3 DW work.

When I try to connect to a site I get connected (according to the log) but then I get a dialog that reads  Toggling the Use Passive FTP checkbox may help you establish a connection.  Select or de-select the checkbox and click Test to try again.  If you are connecting to an IPv6& yadda-yadda. DW fails to download the directory list. There is no way to move a file up or down with DW.

Ive walked through the Adobe troubleshooting steps (KB14834) with these results&

Check for latest version& yes  load from DVD, try no work, download & install all updates, still no joy. Installs are with AV turned off (way faster install).
Make sure site has been defined& Duh!
Is FTP option only choice& Basically for most sites YES
Doc problem. Yep  see below
Did site FTP definition ever work? Yes, long time sailor.
Do other FTP clients function correctly? Yes. WS_FTP and Vista command line ftp.
Can anyone else get DW ftp to work with site? Yes, my other workstation with CS2.
Can I connect to any ftp server from DW?  Once the problem started yes, for a while, after Adobe helped me no.
Are you behind a firewall? Yes, on or off makes no difference. Yes DW CS3 is in the allowed programs.
Use passive ftp. No same problem on those sites that allow it. Most Windows ftp sites refuse passive mode for security reasons. So, this would only help on some UNIX sites. But its mute as same error occurs.
Experiment with Server Compatibly settings. Tried all combinations (about 6 possible). All result in various errors. IPv6 fails quickly with a different error message, as I would expect. My sites are not hosted on IPv6 yet. FTP makes no difference. The ATL FTP does not work, results in login errors.
Verify FTP host info. Yep. Used ftp command line with same info. Site definitions previously worked no changes. Re-entered for one site, problem remains the same. It aint the info.
Change host directory. Yes, no change. Via ws_ftp I enter at site root which has the public folder below. So, I can see the path I need. It previously worked and has not changed.
Disable upload design notes. Makes no difference.
Change site preferences.  Port cannot change for my hosts, 21 it is. Time outs are not an issue. But I changed them. Makes no difference in the time it takes toggle dialog to appear.
Create a new site definition. Tried that too. NO help still get a Toggle dialog.
Recreate the site cache. Done. No help. Tried with several sites. No help.
Drag and drop files& sure, if I only could. I get a stop icon (circle slash) when I drag to remote.
Check the ftp log. This gets to be fun. The log reads that I connected. Actual connection log follows:
< 220-Microsoft FTP Service
 < 220 erebus.propagation.net (Note: server my site lives in and domain points to.)
 > USER (removed)
 < 331 Password required for (removed).
 > PASS
 < 230 User (removed) logged in.
 > PWD
 < 257 "/" is current directory.
 > PWD
 < 257 "/" is current directory.

 > CWD /www
 < 250 CWD command successful.
 > PWD
 < 257 "/www" is current directory
> QUIT      - this appears when I press the disconnect button in DW Files panel.
 < 221  
 > CWD /www/www

There is an interesting thing that happens in the log when a new site definition with a testing server is setup and is used and the Testing Server dialog TEST button. These additional steps are added to the log:
< 250 CWD command successful.
 > MKD MM_CASETEST4291
 < 257 "MM_CASETEST4291" directory created.
 > CWD /
 < 250 CWD command successful.
 > RMD mm_casetest4291
 < 250 RMD command successful.
So, it looks like DW is connecting and able to transfer files.



Folder names, server permissions, ftp command line tools, SFTP?, remote server time, proxy& all tried or not an issue.

Router? I connect directly to DSL modem with static IP address.

New software? Defender updated, ESET/NOD32 of course has updated virus definitions but I have the entire Adobe program folder and sub-folder plus the Roaming user folders for Adobe on the exception list (speed thing).

Now the stuff Adobe had me do. Two re-installs. After one rename the C:\Users\Alan\AppData\Roaming\Adobe\Dreamweaver 9 folder to force rebuild of all configuration data. Then a remove and run msicuu2 and wincs3clean. After that re-install I still have the problem and CS2 stopped working. Now I am removing CS2 as it is no longer useful on this machine.

Ive given Adobe access to one of the sites I have a problem with&  they have escalated the problem. I have little hope of their finding a solution, which is why I am here.

Now leaving Adobes recommendations Ive looked at other possibilities.
IPv6  OK I disabled it. No change. Enabled it.
This workstation is multihomed.  Disabled second network card on local network, reboot, no change. This workstation does not share routing; it just has its own connection to the net. Ive checked routing table and this one uses Internet DNS and metrics are set to use Internet except for local connections. Second card on or off makes no difference.
Autotuning is normally highly restricted.
TCP Global Parameters
----------------------------------------------
Receive-Side Scaling State          : disabled
Chimney Offload State               : enabled
Receive Window Auto-Tuning Level    : highlyrestricted
Add-On Congestion Control Provider  : none
ECN Capability                      : disabled
RFC 1323 Timestamps                 : disabled

Disabling autotuning does not help. Enabling does not help.


With Windows Firewall on or off DW generates the Toggle dialog. Windows is the only firewall on this computer. I checked to make sure Adobe and DW are in the Allowed programs list. They are. DW 8 & 9 have two entries each, TCP and UDP all ports & IPs OK.


With some sites I get two extra messages that say: Connection has been lost. And then:  An FTP error occurred  cannot get remote folder information. Dreamweaver encountered an internal data error. Please try the operation again. The log again shows I am connected and a directory change shows up in the log after the messages.
AACatesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dodge20Commented:
Hello AACates

Have you tried using the IP address instead of the Domain Name? I have seen instances where Dreamweaver has problems resolving the Name.
0
AACatesAuthor Commented:
Yes, same result. Log shows a connect, change directory and then The Toggle dialog comes up.
0
Jason C. LevineNo oneCommented:
I'm willing to bet my firstborn that this is something Adobe is going to have to address with a patch given all the other issues CS3 has generated with Vista.  Sorry, I wish I had some fix or workaround to throw your way.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

AACatesAuthor Commented:
I have been going around with Adobe Support. I have made it past 2nd level to Senior Tech... well I've never actually got to talk to a Senior Tech. But they are going to call me any day now...

I've been told by Adobe over 20 times they were going to call back. It happened once early on. When I call them on they have good stories, 'Oh I'LL CALL YOU. I promise.' The supervior will follow up. Sure.

I am really tired of Adobe's support. I however do appreciate EE's follow up and the expert's comment.

If I should ever get an answer from Adobe, I will post it here. Whatever fix I do find will be here.
0
Jason C. LevineNo oneCommented:
AACates,

Rather than keep this open indefinitely, we should remove it for now.  If and when you get a response from Adobe, you can post a new question and then immediately post the answer under it.  After you do that, you can accept that answer yourself and save the question in the database for future users.
0
AACatesAuthor Commented:
The tech's at Adobe are using this to refer to senior support. So, if you do not mind giveing it another couple of weeks (say 3/24)... I have no problem. If not, I won't be upset with EE.

I did get fed up with Adobe support failing to call back as they prmosed they would. THis has gone on for 6 or 7 weeks now with a promise every week they failed to deliver on. Today was the last call I'll make. They started trying to repeat steps we had been through. Then they wanted me to remove Windows Defender from Vista. When I asked how that was done they wanted me to Google it. Anyone that has worked with Vista knows it cannot be removed (well with out a lot of contortions) it is a service and can be disabled. They wasted days of my time were no help.
0
AACatesAuthor Commented:
It has taken forever...

The problem is NOD32. Adobe uses a file adobelm_libfnp.dll that is a modifed version of lm_libfnp.dll. NOD32 thinks lm_libfnp.dll is an possible virus. It has never complained about this file until just recently, which got me started looking at NOD32.

Remove NOD32 and Dreamweaver CS3 works fine. Appearently a January update to NOD32 created the problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AACatesAuthor Commented:
Today ESET tracked down the problem and provided a solution. Huray! I can keep NOD32 and use DW.

Solution:
Please try doing the following to resolve your issue:
 Bring up the advanced setup window by pressing F5 after you have the ESET interface open.
 Select "Protocol filtering" and select the middle option "Applications marked as Internet browsers and email clients"
 After you have done this go to Web access protection > HTTP > Web browsers.
 Make sure that Dream Weaver is not in the list of Web browsers.
0
Jason C. LevineNo oneCommented:
AACates,

Good work tracking that down.  Thanks for sharing the answer with us.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development Software

From novice to tech pro — start learning today.