How to set MX record for Exchange 2003 SP2 running on Svr 2003 R2

I have an existing 2003 Server R2 box that is functioning as a domain controller and a file server.

I have a second 2003 Server R2 box that will be functioning as my Exchange box.  It is the first instance of Exchange in the domain.  Server R2 with SP2 is set up on this box.  It's joined to the domain as a domain controller and DNS is configured on it.  Replication works both ways.  Exchange 2003 is installed with SP2.

I have an existing e-mail server - an old Linux box that's about to die.  I'm not worried about migration... I'm going to manually move each user's e-mail over once the new server is up.  

My real-world public MX record is set to the public IP of my router.  Currently the router is NAT forwarding port 25 to my Linux e-mail server.  I will be updating this to the Exchange server.  

The internal FQDN of the Exchange box is:   servername.domain.local
E-mail will be coming in on our public domain name:  emailname@fulldomain.com

The domain.local and fulldomain.com are different.  (It's not domain.local and domain.com)

When I telnet to the Exchange box using the internal IP, it shows servername.domain.local
However, when I briefly change the router NAT to forward to the Exchange server and then telnet to the public IP from an external connection, it still shows servername.domain.local

Obviously I need to set this so it shows as (mail?or servername).fulldomain.com  (In this instance, should I just use the NetBIOS name of the mail server or is it best to use mail. ?)

Here's the question.  Which DNS entries do I need to create?  Sorry it took so many words to ask it but I wanted to provide a thorough background.  (And make it easier for others to search for in the future.)

I'm hoping to get this box fully operational in the next day so any assistance is greatly appreciated.
LVL 1
DynamiteMonkeyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mass2612Commented:
Hi,

You need to have a A (host) record for mail.yourdomain.com and the MX record. You should also update the SMTP banner on the server.

This site by Simon should cover it for you - http://www.amset.info/exchange/dnsconfig.asp
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DynamiteMonkeyAuthor Commented:
OK... I changed the SMTP banner.  I've changed it to mail.fulldomain.com and am in the process of having mail.fulldomain.com redirected by my host to the IP of my router.

A little more info for adding the A and MX record.

The mail will be coming in directly to the IP of my router.  Its format will be emailname@fulldomain.com

The website, www.fulldomain.com is hosted elsewhere and is nothing to do with these servers.  

I currently have two forward lookup zones on my DNS servers.  _msdcs.domain.local and domain.local

Do I need to create another full zone for fulldomain.com or do I add it under one of the local zones?  I know this is a basic question but it has been so long since I've set up a system in this configuration - I just can't remember.  I know that if I add a new zone for fulldomain.com, it's going to mess with the internal routing of all the externally hosted fulldomain.com

0
mass2612Commented:
Unless you are hosting mutiple DNS servers that are open to the Internet you should have your host record and MX record created and hosted on your ISP's DNS servers. It's pretty rare even for large companies to host and manage an Internet facing DNS server so this is probably managed via your ISP.

You MX record will point to your router's which I think you are having changed but your router will then normally be set to forward requests on port 25 to the internal IP address of your SMTP gateway which is sometimes your Exchange server or SPAM/virus filtering server etc.

You should not need to create these Internet records or zones on your Internal DNS server.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

DynamiteMonkeyAuthor Commented:
My host record and MX record are set up on my ISP's DNS servers.  I just had them create mail.fulldomain.com and it is now pointing at my router as of this morning.  

Both of my internal servers are running DNS, but only so as to support Active Directory and provide DNS lookup for connected workstations.  My internal DNS servers have absolutely nothing to do with the company website or anything else fulldomain.com related.  

Currently I have an A Host record for the internal NetBIOS name of my mailserver and it is under domain.local in the DNS config.  I don't have an MX record in there yet.  Do I need to create one and if so, where?  When I go to create one under domain.local, it is forcing the FQDN to mail.fulldomain.com.domain.local

As it is right now, when I temp forward port 25 to the Exchange box, I don't receive mail from outside the network.  
0
mass2612Commented:
You should not need the mail.fulldomain.com internally. Your MX record normally points to the public IP of your router, your router forwards requests on port 25 to the internal IP of your SMTP gateway/Exchange server.

Can you telnet to your server i.e.

Internally : -
telnet exchangeservername 25

Externally: -
telnet mail.fulldomain.com 25

Here are some tools to test your MX record and if port 25 is accepting connections: -
http://dnsgoodies.com/
http://www.zmailer.org/mxverify.html
http://www.t1shopper.com/tools/port-scanner/
0
DynamiteMonkeyAuthor Commented:
OK... mail is now being delivered to the Exchange server.  I checked the SMTP Virtual Server and everything looked all right but I found another topic where someone said they had to restart the VS.  I tried it an dit worked.  Go figure... I don't get that since I rebooted the server too... Anyway... mail delivery is working.

However, I'm having trouble sending mail.  I have a Hotmail account and another third party account I'm using as test accounts.  When I send mail from those accounts, it gets delivered fine.  When I reply to those messages, I get a bounce back saying this:  (from Hotmail)


There was a SMTP communication problem with the recipient's email server.  Please contact your system administrator.
            <mail.fulldomain.com #5.5.0 smtp;550 DY-001 Mail rejected by Windows Live Hotmail for policy reasons.

If I send mail from my old server, it gets through fine so it's not an IP address blacklist.  Everything in Exchange is set up as per the default wizard settings.  I don't have a smart host in the SMTP VS.  

I'm going to work through this one and there seems to be lots of info on it but any help would be appreciated.
0
mass2612Commented:
There are heaps of reasons why this could be happening mostly related to SPAM lists, reverse DNS records not being correctly setup at the ISP, etc. It could also be that the DNS updates at your ISP have not fully replicated and the Hotmail side may be picking up stale DNS entries that will fix itself with some more time normally.

http://postmaster.live.com/Troubleshooting.aspx
0
DynamiteMonkeyAuthor Commented:
OK... I'm going to sign this one as answered and I'll start a new question if needed.

Thanks for all your assistance.
0
DynamiteMonkeyAuthor Commented:
Thanks again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.