Companion 5 speakers stuck on either standby or off, no sound in either case

Hey guys,

I'm sorta stuck here and I really don't know what to do. Well this is sorta whats happening, I have a set of Bose Companion 5 Speakers hooked up to my laptop through a USB port and they were working beautifully since I had purchased them which has been almost 5 months. However, just recently, instead of the normal green (active/on) light, and the amber (muted) light, it has always been on red (standby) or no light at all was displayed on the control pod.
The even stranger thing is that when no light is present, and I am trying to play sound through my speakers, there will be occasional sound, as it will play for 2-5 seconds, then go mute for an extended period, and so on. I have a feeling it is something to do with the speakers and not with the laptop because it does not work when plugged into different USB ports and also I have tried to disconnect and reconnect everything to no avail.
I think the biggest note to mention is that a couple of days ago the area around my control pod had water spilled on it, which I have no idea if it affected it or not (seems like it did). But even after that, for a day the speakers continued to work, and until recently did they behave they are right now...


Alright well thats the whole thing the best way I can sum it up. Sorry its so long but Thanks again for helping me out. I'm really at a loss here...and I don't wanna have to get new speakers because these were pretty pricey...

but yea thanks again

running vista, on a Sony Vaio Core 2 Duo 1.8 Ghz 2 Gb Ram
mehta29Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pheidiusCommented:
Test them with a different system to isolate the issue.
0
mehta29Author Commented:
Thanks though but I actually got it. It was actually just the moisture on the inside of the control pod...I used light bursts of hot air (blew into it) and eventually it regained function. Elementary but it fixed the problem.



0
pheidiusCommented:
woohoo
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

mehta29Author Commented:
Waitttttttttttt!!!!!!!!!!!!!!!!!
Please don't close this question...I thought I had achieved a solution, when I really didnt....

Okay, so that was a temporary fix.
I tried compressed air afterwards, did not make things any better.
Back to the Red/ No light status.

I plugged it into my roomates laptop and same issue (I'm on a college campus).
However, now theres a new quirk,
when the red light is on (supposedly meaning standby) my volume works, but remains at max volume and cannot be adjusted.
So now I am stuck between No sound and Deafening. Any help would be much appreciated.



0
mehta29Author Commented:
I just replaced the part, no real solution.
0
Computer101Commented:
PAQed with points refunded (300)

Computer101
EE Admin
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Home Theaters

From novice to tech pro — start learning today.