Weird Windows Explorer Issue - GPO?

Okay so I took over for the person before without receiving any information regarding the setup of the group policy for a particular group of users.  This group of users has several things locked down to prevent them from doing certain things.  For instance, they do not have access to the C drive.

So now here is the weird thing.  If you are in Word or Excel (etc) and go to open a document you are able to see the available drive in My Computer (floppy drive, network drive, cd-rom drive, usb flash if you have one inserted).  But if you are using a website (in Internet Explorer 7 or Mozilla FireFox 2) that allows you to upload a file (like Monster.com and a resume), you are only allowed access to the desktop.  The Open File dialog window does not list My Computer or any of the other drives as options in the drop down.

I am assuming (and hoping) that this has something to do with the GPO.  The only other thing I could think of is that these users use machines with DeepFreeze on them, but I have never seen a setting in DeepFreeze that would affect this.  Any ideas?
parkridgelibraryAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

parkridgelibraryAuthor Commented:
QUICK UPDATE:
----------------------

Apparently the only program that allows you to see the contents of My Computer is MS Word (2007).  Excel and PowerPoint (2007) act the same way as Internet Explorer and FireFox.  I had assumed that since Word worked the other office suites would too.  I just had it confirmed that they do not however.
0
elissaqpCommented:
It is because when you use File / Open, you get a window that "always" will show you my PC, it does not depend of the GPO.  At least it is no way to disable the buttons on the left of that window.

The only solution i see is to change the location of you files from MS word for example: Tools / Options / File Locations.
0
parkridgelibraryAuthor Commented:
I don't think I was clear above.  MS Word is the only program that is acting the way I would like it to.  Internet Explorer, FireFox, and MS Excel are the programs that do not allow you to see anything other than the Desktop when you attempt to Open a file (ie, the Open File dialog window).  I want them to work like Word, where you can access and see the contents of My Computer.
0
parkridgelibraryAuthor Commented:
I fixed the issue myself as it was related to the local and global GPO on our network.  Thanks anyways though!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.