?
Solved

Leopard Volume Mounting Issues

Posted on 2008-01-30
7
Medium Priority
?
800 Views
Last Modified: 2012-08-14
I have a script I used in Tiger that mounts SMB volumes. In Leopard these scripts don't work

The heart of the script would do:

for smb:
mount volume "smb://userName:password@serverName/volumeName"

I have many users requiring multiple mapped drives with varying permission levels.
When I enter an actual user and their password into the script it works, but the script above which worked before won't run now in 10.5

Any comments are welcome...
0
Comment
Question by:bountycyclops
  • 4
  • 2
7 Comments
 
LVL 41

Expert Comment

by:Eoin OSullivan
ID: 20785327
Remove the username and password
mount volume "smb://serverName/volumeName

It should then prompt to login .. if you save the username/password in the keychain then it should reconnect in future.
0
 

Author Comment

by:bountycyclops
ID: 20789679
Thanks for your reply

Yeah the problem I have is different users who each have different permissions and the keychain would be storing a single password. The line in the script is there so that their own authentication is used.
0
 
LVL 41

Expert Comment

by:Eoin OSullivan
ID: 20791959
Are all these different users using the same account on OSX and not logging in and out as separate user accounts?
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 

Author Comment

by:bountycyclops
ID: 20792076
No they are all logging in with their own separate accounts.
0
 

Author Comment

by:bountycyclops
ID: 20792100
Sorry I should have mentioned we have multiple Mac's bound to active directory, multiple user logging on to both Mac's and PC's with the same AD account.
0
 
LVL 7

Expert Comment

by:vishal_impact
ID: 20839829
OK this should not affect
As just check by going into system preference first that samba protocol is enabled
then by going into applicaion>>utilities>>directory untilities join it to the active directory.
Then type this command which you showed above
I hope that you have enabled the services on server side for mac as you said you were previously conncting with the same server and active directory with mac tiger.
0
 

Accepted Solution

by:
bountycyclops earned 0 total points
ID: 20862362
Thanks for your input guys, have rolled back to Tiger, will take  your advice vishal_impact  in the future when we do move forwards with Leopard.

Ta
0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Worried about if Apple can protect your documents, photos, and everything else that gets stored in iCloud? Read on to find out what Apple really uses to make things secure.
This article outlines the struggles that Macs encounter in Windows-dominated workplace environments – and what Mac users can do to improve their network connectivity and remain productive.
How can you see what you are working on when you want to see it while you to save a copy? Add a "Save As" icon to the Quick Access Toolbar, or QAT. That way, when you save a copy of a query, form, report, or other object you are modifying, you…
If you are looking for an automated solution for backup single or multiple Office 365 user mailboxes to Outlook data file, then you can use Kernel Office 365 Backup & Restore tool. Go through the video to check out the steps to backup single or mult…
Suggested Courses
Course of the Month7 days, 1 hour left to enroll

592 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question