Could not find package libaio

I am using Ubuntu 7 Linux system
I tried to run following command

>sudo apt-get install build-essential libaio rpm lesstif2-dev alien

Error I get
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E: Couldn't find package libaio


How to fix such types of problems in Ubuntu? I am new to Ubuntu OS usage.
gauravflameAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

yjwongCommented:
Are you using Ubuntu 7.04 or 7.10? According to the Ubuntu package search, the package is available in the repositories. Try enabling the Universe repository in (System -> Administration -> Software Sources) and refresh the package lists.

Libaio is available as the package "libaio1" (note that extra 1).
0
gauravflameAuthor Commented:
I am using Ubuntu 7.10. Actually I installing Oracle 10g in my system that why I require to
enable the universe rep.

Can you tell me someother way to enable Universe repository on my system(Ubuntu 7.10) ?
0
http:// thevpn.guruCommented:
Another way would be to edit the file

/etc/apt/sources.list and then remove the # from the front of the lines that have Universe at their end .
Then apt-get update then try again
You might also want to try libaio1 first as mentioned before.

You can search for it using

apt-cache search libaio
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

gauravflameAuthor Commented:
I update my sources.list file and

did search via apt-cache search libaio
Result I got:

libaio-dev - linux kernel aio access library - development files
libaio1 - linux kernel aio access library - shared library



0
yjwongCommented:
"libaio1" should be the package you wanted. Just change "libaio" into "libaio1" in your initial command.
0
gauravflameAuthor Commented:
Now I again tried the following command

>sudo apt-get install build-essential libaio rpm lesstif2-dev alien

I get the below Error::
""...................
0 upgraded, 42 newly installed, 0 to remove and 0 not upgraded.
Need to get 17.8MB/25.3MB of archives.
After unpacking 95.0MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Media change: please insert the disc labeled                              
 'Ubuntu 7.10 _Gutsy Gibbon_ - Release amd64 (20071016)'
in the drive '/cdrom/' and press enter
................."

0
gauravflameAuthor Commented:
tried libaio1...
....It talking about "Insert Disc " ... which disc ?
0
yjwongCommented:
The disc is your Ubuntu installation CD. If you don't want to use the CD, or if you don't have the CD, open your /etc/apt/sources.list and comment (add a preceding "#" in front) this line:

# deb cdrom:[Ubuntu 7.10 _Gutsy Gibbon_ - Release amd64 (20071016)]/ gutsy main restricted

That should work for you.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
http:// thevpn.guruCommented:
well the thing is that your repos are set to search in the disk not on the Internet try this

# Ubuntu supported packages (GPG key: 437D05B5)
deb http://archive.ubuntu.com/ubuntu gutsy main restricted
deb http://archive.ubuntu.com/ubuntu gutsy-updates main restricted
deb http://security.ubuntu.com/ubuntu gutsy-security main restricted

deb-src http://archive.ubuntu.com/ubuntu gutsy main restricted
deb-src http://archive.ubuntu.com/ubuntu gutsy-updates main restricted
deb-src http://security.ubuntu.com/ubuntu gutsy-security main restricted

# Ubuntu community supported packages (GPG key: 437D05B5)
deb http://archive.ubuntu.com/ubuntu gutsy universe multiverse
deb http://archive.ubuntu.com/ubuntu gutsy-updates universe multiverse
deb http://security.ubuntu.com/ubuntu gutsy-security universe multiverse

deb-src http://archive.ubuntu.com/ubuntu gutsy universe multiverse
deb-src http://archive.ubuntu.com/ubuntu gutsy-updates universe multiverse
deb-src http://security.ubuntu.com/ubuntu gutsy-security universe multiverse

# Ubuntu backports project (GPG key: 437D05B5)
deb http://archive.ubuntu.com/ubuntu gutsy-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu gutsy-backports main restricted universe multiverse

# Ubuntu Proposed packages (GPG key: 437D05B5)
deb http://archive.ubuntu.com/ubuntu/ gutsy-proposed restricted main multiverse universe
deb-src http://archive.ubuntu.com/ubuntu/ gutsy-proposed restricted main multiverse universe

#Canonical Commercial Repository
deb http://archive.canonical.com/ubuntu gutsy partner
#deb-src http://archive.canonical.com/ubuntu gutsy partner

# UbuntuStudio Repository (GPG key: B6A4EB33)
#deb http://archive.ubuntustudio.org/ubuntustudio gutsy main
#deb-src http://archive.ubuntustudio.org/ubuntustudio gutsy main

# Bleeding edge wine packages
deb http://wine.budgetdedicated.com/apt gutsy main
deb-src http://wine.budgetdedicated.com/apt gutsy main

# Seveas packages (GPG key: 1135D466)
# GPG key-file: http://mirror.ubuntulinux.nl/1135D466.gpg
deb http://mirror.ubuntulinux.nl gutsy-seveas all
deb-src http://mirror.ubuntulinux.nl gutsy-seveas all

# Upstream Opera (GPG key: 6A423791)
deb http://deb.opera.com/opera etch non-free

# Upstream Beryl (GPG key: ed8a569e)
deb http://ubuntu.beryl-project.org/ edgy main
deb-src http://ubuntu.beryl-project.org/ edgy main

# Medibuntu - Ubuntu 7.10 "gutsy gibbon"
# GPG key-file: http://packages.medibuntu.org/medibuntu-key.gpg
deb http://packages.medibuntu.org/ gutsy free non-free
#deb-src http://packages.medibuntu.org/ gutsy free non-free
0
http:// thevpn.guruCommented:
Comment out the depos that point to a cd rom first
0
pointerstopCommented:
You should always ask yourself _why_ you would be installing any lib* package.  Generally speaking you don't need to on any Debian-based system, as they're brought in automatically to resolve dependencies.

In this case you do need libaio, not libaio1, because Oracle-xe depends on it, and you get libaio from the same place you got oracle-xe.
0
gauravflameAuthor Commented:
Thanks my problem is solved !
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.