HTTP Error 401.3 when accessing files on IIS 6.0

When trying to access files via our IIS 6.0 web server, I keep getting the following error:

You are not authorized to view this page
You do not have permission to view this directory or page due to the access control list (ACL) that is configured for this resource on the Web server.
--------------------------------------------------------------------------------
Please try the following:
Contact the Web site administrator if you believe you should be able to view this directory or page.
Click the Refresh button to try again with different credentials.
HTTP Error 401.3 - Unauthorized: Access is denied due to an ACL set on the requested resource.
Internet Information Services (IIS)

We require anoyomous access for this website which is setup but I have read that the IUSER_<server> needs NTFS permissions to access all files. I have looked at the folder where our files are located and all of the permissions are locked out. Any suggestions on this are appreciated.

Regards,
RM
rmullins83Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RubalJCommented:
This is very common permission issue. You dont have to lock permission. You have to allow IUSR_ServerName RLX / Modify permission on the domain's root directory.

Check out the following MS KB on howto do it with complete details

http://support.microsoft.com/kb/271071/

Thanks
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rmullins83Author Commented:
That document applies only IIS 5.0 and not IIS 6.0, is there another solution specific to the version of IIS that I am using?
0
RubalJCommented:
That should work for IIs6.0 as well ..
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

rmullins83Author Commented:
Every link seems to say that changing the 'Security' tab settings for the website folder so that IUSER_<server> can access is solution. But the permissions are all greyed out so I cannot modify anything. IUSER account is listed.
0
harperseCommented:
You need someone with administrator rights on the server to investigate.  Also, assign the rights to the IIS_WPG group, and not the individual service accounts, (IWAM, IUSR, Network Service, etc.)

Best of luck,
harperse
0
rmullins83Author Commented:
I assume this is the write, read and modify rights that need to be assigned to the IIS_WPG group?
0
harperseCommented:
Usuallt not write, just read and execute.  Unless the web site writes to itself (HTML inline editor, etc.), I never give write access to a web site.

Best of luck,
harperse
0
rmullins83Author Commented:
Have noticed that I am able to access the .html files but no other files types.
0
harperseCommented:
ASP is not enabled by default on IIS6.  Go to IIS Manager, then Web Service Extensions, and change Active Server Pages to allowed.

Best of luck,
harperse
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.