Why can't I delete my Exchange 2007 Recovery Storage Group?

I open the Exchange 2007 Managemnet Console and select TOOLBOX - Database Recovery Management.  I then put in my server/user information and select NEXT.  After selecting "Mount or dismount databases in the recovery storage group", then selecting the mounted Recovery Storage Group Database, followed by "Dismount the selected database", I receive a "Database 6 successfully dismounted" message.  I then select "Go back to task center' and "Remove the recovery storage group".  I then receive a message that....."The recovery storage group cannot be removed if any databases are mounted.  Go back to the task center, select 'Mount or dismount databases in the recovery storage group' task to dismount all databases, and then try again.  This is a never ending cycle.  I've even tried to delete the database manaully from the E:\ and F:\ drives, but I get an error saying "Database is in use".  Does anybody have any idea why I can not delete the Exchange 2007 Recovery Storage Group?  Thanks.
mccrear1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

UbuntopCommented:
I cannot directly answer as to why the Recovery tool is not dismounting the DBs, but there are other options.  Have you tried removing it from within the EMC?

Otherwise try this in the Shell.
Remove-MailboxDatabase Identity ExcServer\Recovery Storage Group\Mailbox Database
Remove-StorageGroup Identity ExcServer\Recovery Storage Group
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cedarghostCommented:
Remove-MailboxDatabase -identity <Server_Name>\<RSG_Name>\<Database_Name>
Remove-Storagegroup -identity "<Server_Name>\<RSG_Name>"
The mailbox database has to be deleted first. That's what the first command does. Then you can delete the Storage Group.
You also need to be the Exchange server administrator and a member of domain administrators if on a domain or local admins if not.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.