Disk defragmenter won't open (vista)

I am running Vista business 32bit
Disk defragmenter won't open.
It shows the windows needs your permission to continue text, but when I click continue it just closes the program.
I tried opening it from the command line and got the same result, without any explanatory text

Thanks
LVL 9
peterdunganAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MotoCrazyCommented:
Disk defrag in Vista runs in the background. Are you sure it is not running? Check your task manager, and I bet you will see it is working.
http://www.pcworld.com/article/id,134986-page,1-c,microsoftoffice/article.html

Microsoft on Vista's defrag:
http://support.microsoft.com/kb/942092
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rbudjCommented:
Forget doing it that way.  i hate the new defrag utility.  Instead click Start > All Programs > Accessories > Right click the command prompt > Run as Administrator.

Once you see the dos window type: defrag.exe c:

This way, you can see the % that your drive is fragmented.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Vista

From novice to tech pro — start learning today.