Exchange Helo putting our domain on the CBL block list

Our exchange server has been a nightmare to keep off the block list. From NDR Spam, to helo issues.

the way things are setup the companies domain is being used for web hosting at an external hosting company...   we have the MX records setup to pass off emails to postini, which then delivers them to our exchange server.

with this the domain let's say ourcompany.com doesn't have the same ip address as the exchange server. initially the server was setup to say ourcompany.com in the HELO when directly sending out emails. That got us on the CBL list for the ip address of the domain not matching up with what the exchange server was saying it was. So we used the domain tw.ourcompany.com to point to the exchange server and had the exchange server identify itself. Everything was good for about a day or so..

Yesturday from 1am until noon Time Warner Road Runner connect was out after a storm. Our sonicwall firewall is setup to fail over to a secondary half t1 we have through xo. So it did that. now we are back on the CBL list as of yesturday. the xo pipe is setup as xo.ourcompany.com.

So the question is how can I get the Exchange server to work universally in terms of a helo, no matter which internet connection is being used.

Honestly I'm tired of having to dance around all these little things each Block List does to try and prevent spammer since the email infrastructure is flawed. I really need an answer to this question and a good tutorial on setting up an exchange server to no get blocked at all the different Block lists.
LVL 11
IsisagateAsked:
Who is Participating?
 
dan_blagutConnect With a Mentor Commented:
Hi
I must admit that i don't seems to fully understend you.
You need that your server to respond with same name at helo whatever connection is used? Then put a router in front of this server and connect the server with NAT to this router

Dan
0
 
IsisagateAuthor Commented:
How about this,

Is there a way to dynamically set the fqdn for the helo based on which outgoing connection we use at the time?
0
 
dan_blagutCommented:
Actualy in this config you don't need to set the fqdn because the server has only one name. The router has two IP.
0
 
IsisagateAuthor Commented:
In the end we ended up adjusting the exchange server to send out through a smart host provided by our internet service provider. That way it's their problem, not ours.
0
All Courses

From novice to tech pro — start learning today.