Virtual Server MAC address conflict when restarting hardware

Wipfli
Wipfli used Ask the Experts™
on
I have a Windows 2003 R2 - 64bit server running the native OS, and a Windows 2003 R2 -32bit virtual server session.  Both the native and virtual sessions are sharing the same NIC.  When I reboot the native OS session, on restart the Virtual session doesn't start and generates a MAC address in use error.  

To get the Virtual server session running, I must kill the virtual server using taskkill /PID <ID> /F command.  

Then I can open the virtual server manager and manually restart the virtual server.  

What is the proper way to setup the virtual server to avoid this conflict at reboot?  Thanks you,
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Amit BhatnagarSystems Development Principal - Security and Infrastructure

Commented:
Weird...!! To say the least...There is no 'Proper Way' of configuring the Virtual Server and normally, no conflict should occuer. I am assuming that both the machines, Host and Virtual have different static IPs assigned to them. Anyways, try deleting the VNC files and creating them once again using the Virtual Network wizard. See if that helps !!

Author

Commented:
Is there a down and dirty best practices paper to use when setting up the networking of the virtual server?  
Amit BhatnagarSystems Development Principal - Security and Infrastructure

Commented:
I am sorry, I have never used one. But, Yes one of my favorites ways is to create a Microsoft Loopback Adapter and then bind all the internal machines to it. Then configure RRAS on Host Machine so that it can be used as NAT Device to take the VM out to the Physical Network. But then again, I had my own reasons to do it. Can you tell me, what is your setup right now and what are you planning to setup?
OWASP: Threats Fundamentals

Learn the top ten threats that are present in modern web-application development and how to protect your business from them.

Author

Commented:
The server has dual NICs, but one is disabled.  I've got the native OS setup to use a unique IP address, then in the virtual server settings I'm using this NIC as well, with a different IP address in the actual virtual server session.  

Packets flow properly, and I've done it like this for other installs without problems (that I know of).  

I'll do some digging on MS's site for a whitepaper and see if I can find anything on thier recommendations.  
Amit BhatnagarSystems Development Principal - Security and Infrastructure

Commented:
Sure thing. I will try and search as well. Although, in the mean time can you please let me know what is the MAC address of the enabled NIC, Disabled NIC and the NIC within the Virtual Server. You can get the MAC using the simple 'ipconfig/all' command.
Also, the MAC address conflict must be generating a Event ID within the EventViewer. Can you paste the information here. Thanx !!

Author

Commented:
I found a "best practices" doc on Microsoft's site, although there is nothing specific how to setup.  
http://technet2.microsoft.com/windowsserver/en/library/3bc3c85f-668e-4730-bfd8-73fd2d12c21c1033.mspx?mfr=true
To generate the error, I'll need to reboot the server.  This may be a couple weeks before the next window.  I'll post when I complete the reboot and best practices section.


Amit BhatnagarSystems Development Principal - Security and Infrastructure

Commented:
Hmmmmm so it means we are not getting any errors within Event Viewer, right? Anyways, sure please keep me updated. Although, you did not mention the MAC Address of the machines involved.

Author

Commented:
Some additional information:
I ran the ipconfig /all on the physical server and received the following MAC address:
00-15-17-3d-28-44.

When I go to the virtual machine properties-->Network adapters section, under the virtual server manager GUI, I see the Virtual network adapter 1 is "Connected to "External Network (Intel) PRO_1000 PT Server Adapter" with current Ethernet (MAC) address of 00-15-17-3d-28-44.

When I go into the virtual server session itself and do an ipconfig /all, I get a different MAC address 00-03-FF-38-28-44.

Is this the expected behavior?  
Commented:
Found the solution.

I had hard-coded the IP address into the physical NIC, then within the virtual session also used the same IP address.

To resolve, I used a DHCP address for the secondary physical NIC, then assigned that NIC to the virtual server and setup the proper static IP in the virtual server session.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial