Windows Volume Shadow copy error 0x8004230f

I have a Windows 2003 server running x64 sp2. It's mission in life is file serving. When I try to configure Shadow copies I get:
Failed to retrieve volumes that are eligible for shadow copies. error 0x8004230F.

This is a brand new IBM server with two 1TB drives in Raid 1. We have an identicle server configured at the same time that has no problems. Anyone have a clue?

Thanks in advance,
LVL 13
murgroupAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

murgroupAuthor Commented:
Event id 12293 in event viewer
0
Madison PerkinsConsultantCommented:
What are you using to back up the system?  Do you have SQL 2005 or 2005 express running on the system?

copy and paste the event id please.  

Take a look at this thread.
http://forums.msrportal.com/archive/index.php?t-10721.html
0
Madison PerkinsConsultantCommented:
I meant copy and paste the entire event from your event log.
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

murgroupAuthor Commented:
No backup configure yet. It did this out of the box. Already registered those dll's before I posted here. No SQL installed or running.
0
murgroupAuthor Commented:
Event Type:      Error
Event Source:      VSS
Event Category:      None
Event ID:      12293
Date:            1/31/2008
Time:            6:55:22 PM
User:            N/A
Computer:      MUSUBI
Description:
Volume Shadow Copy Service error: Error calling a routine on the Shadow Copy Provider {b5946137-7b9f-4925-af80-51abd60b20d5}. Routine details IVssSnapshotProvider::QueryVolumesSupportedForSnapshots(ProviderId,29,...) [hr = 0x8000ffff].

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 2d 20 43 6f 64 65 3a 20   - Code:
0008: 43 4f 52 4d 47 4d 54 43   CORMGMTC
0010: 30 30 30 30 30 33 32 34   00000324
0018: 2d 20 43 61 6c 6c 3a 20   - Call:
0020: 43 4f 52 4d 47 4d 54 43   CORMGMTC
0028: 30 30 30 30 30 32 38 30   00000280
0030: 2d 20 50 49 44 3a 20 20   - PID:  
0038: 30 30 30 30 32 32 32 34   00002224
0040: 2d 20 54 49 44 3a 20 20   - TID:  
0048: 30 30 30 30 32 34 32 34   00002424
0050: 2d 20 43 4d 44 3a 20 20   - CMD:  
0058: 43 3a 5c 57 49 4e 44 4f   C:\WINDO
0060: 57 53 5c 53 79 73 74 65   WS\Syste
0068: 6d 33 32 5c 76 73 73 76   m32\vssv
0070: 63 2e 65 78 65 20 20 20   c.exe  
0078: 2d 20 55 73 65 72 3a 20   - User:
0080: 4e 54 20 41 55 54 48 4f   NT AUTHO
0088: 52 49 54 59 5c 53 59 53   RITY\SYS
0090: 54 45 4d 20 20 20 20 20   TEM    
0098: 2d 20 53 69 64 3a 20 20   - Sid:  
00a0: 53 2d 31 2d 35 2d 31 38   S-1-5-18
0
Madison PerkinsConsultantCommented:
Are both Microsoft Software Shadow Copy Provider and the VSS service set to manual?  can you start these services manually with out an error?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
murgroupAuthor Commented:
Both were on manual. Started both and now I can configure shadow copies for the C drive shares. If those services stop will shadow copies fail?
0
Madison PerkinsConsultantCommented:
sheduled shadow copies should start the services.  shedule a shadow copy fifteen minutes from now then rebbot the box.  look at the services to check the state,  wait until after the scheduled shadow copy should start and verify that the copy happened.
0
murgroupAuthor Commented:
I rebooted and both services started even though they are on manual. I can still configure shadow copies and set it to create on at 8:10 PM PST. Will let you know what happens.
0
murgroupAuthor Commented:
Ok the Shadow copy complete at 8:10 PM. I will watch this over the next several weeks and see if any other problems arrise. Thanks for the help.
0
murgroupAuthor Commented:
Thanks so much for the help. Best Regards,
Brad
0
mcvay178Commented:
Worth mentioning for anyone who happened to start the services mentioned above:

I was receiving the same error when trying to perform manual system state and drive backups.  I did not have VSS enabled on any of my three mirrored drives and needed VSS to be enabled for the backup to run but received an error when trying to access the VSS tab within computer management.

After reading a post above regarding SQL, I worked through database services and shut down the SQL server with no positive effect on the error.  After working a little while longer, I dismounted my encrypted backup drive and shut down TrueCrypt and I all of a sudden gained access to the shadowcopy tab.

Make sure all encryption software is shut down and it may be a good measure to take any SQL databases offline when trying to get this fixed.  (there is a specific VSS related SQL service.  Not sure if this has any effect on this problem)
0
nopainnogain1Commented:
mcvay178 is correct: Dismount TrueCrypt drives and it worked immediately.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.