OWA http 400 bad request error

I have an sbs 2003 BE/FE server that I am having OWA problems. If I try to get into owa on the server, or outside the domain I get an HTTP 400 Bad Request error.  I tried using servername/exchange and 127.0.0.1/exchange, as well as External_IP/exchange.  They all do the  same thing from both the server or outside PC's.  
degoodwinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

HusbiCommented:
Have you looked at this article ?  http://support.microsoft.com/kb/842693
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
degoodwinAuthor Commented:
I had looked at it but I checked it again and realized that the default port was set to 8080 and not 80. I changed it and it works now.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.