Event ID 10016 - DCOM

I get the following message over and over again in the event viewer and I don't have a clue how to get rid of it.

The application-specific permission settings do not grant Remote Activation permission for the COM Server application with CLSID
{F4B099F4-6F6C-11D2-A7A9-00A02495D99E}
 to the user NT AUTHORITY\ANONYMOUS LOGON SID (S-1-5-7).  This security permission can be modified using the Component Services administrative tool.

Event ID 10016
User NT Authority\Anonymous Logon
AJNSAsked:
Who is Participating?
 
cbmmConnect With a Mentor Commented:
find out what F4B099F4-6F6C-11D2-A7A9-00A02495D99E is in your registry

Open the registry and go to ?HKEY_CLASSES_ROOTCLSID{<CLSID in the event message>} to find out friendly name of this component. In my case, this is "Machine Debug Manager? (CLSID: 0C0A3666-30C9-11D0-8F20-00805F2CD064).
2. Go to Component Services via Start -> Control Panel -> Administrative Tools -> Components Services. Expand the Component Services branch then expand ?Computers?, ?My Computer?, and ?DCOM Config?. Right-click on "Machine Debug Manager" (or whatever your CLSID represents) and choose Properties. Click on the Security tab and under ?Launch and Activation Permissions? select ?Use Default?. Click OK, close the Component Services window. The error should disappear now.
0
 
AJNSAuthor Commented:
I'm very impressed. That lead me right to it. Unfortunately the application is not listed in DCOM but I at least now know its one of HummingBird's Dll's. I'll pass it along to them to sort out.

Thanks
0
 
kaylanreilorCommented:
There is also something here:
http://support.microsoft.com/kb/931355/en
Did you read it already ?
Are you talking about a componenet that YOU developed ?
0
 
cbmmCommented:
if its in the registry and not in DCOM that could  be the reason you are getting the error
0
 
PhilstarfishCommented:
how do i add this to the DCOM so i can assign the correct permissions?
0
All Courses

From novice to tech pro — start learning today.