• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 489
  • Last Modified:

SQL 2005 running slow - AWE memory?

We have a SQL database that seems to be gradually getting worse - I've done the usual things - profiling index etc looking at the memory it appears to stay at 1.6GB and this may (?) be the problem. The server has 8GB has /PAE set in the boot options.

However when I try to tick Enable AWE memory in server properties I get a failure with "Requires lock memory permissions".

1. Can this be done on the fly or do I need to get users out?
2. If it can be done - how do I do it?
3. Any other potential area's to look at on the server config?

Cheers
Si
0
Netstore
Asked:
Netstore
1 Solution
 
brejkCommented:
1. No, you need to restart SQL Server service
2. http://msdn2.microsoft.com/en-us/library/ms190730.aspx
3. /3GB and /PAE switch in boot.ini, AWE enabled in SQL Server instance, server max memory set to 7500 (with 500MB left to OS)
0
 
dvs_markCommented:
The LOCK PAGE IN MEMORY permission must be granted to the SQL Server account before enabling AWE. For more information, see How to: Enable the Lock Pages in Memory Option (Windows).
0

Featured Post

Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now