How to change IP address on Cisco ASA 5505 with adsm

Hi,
I've purchased the cisco ASA 5505.
I want to configure the ASA with ASDM. The default IP address on the ASA is 192.168.1.1. I want to change it to the 192.168.0.0 range (for examp. 192.168.0.1). This because my LAN is on the 192.168.0.0 range. But when I'm change it (even with the startup wizard), ASDM can't save it to the ASA (ERROR in sending command).

please help??
vturbaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

2PiFLCommented:
Try disabling the dhcp pool first.
0
2PiFLCommented:
You'll most likely have to do it from the commnd line:

ASA# conf t
ASA#(configur)no dhcp service
ASA#(configur)exit
ASA#wr m
0
vturbaAuthor Commented:
I did.. :(
0
IT Degree with Certifications Included

Aspire to become a network administrator, network security analyst, or computer and information systems manager? Make the most of your experience as an IT professional by earning your B.S. in Network Operations and Security.

vturbaAuthor Commented:
- DHCP turned off

Ip change with command line;

conf t
int vlan1
ip address 192.168.0.1 255.255.255.0
exit
write mem

The command is send successfully to the ASA, but still the default IP (192.168.1.1) is assigned to VLAN1.  :( :(

0
batry_boyCommented:
From the command line, try this:

conf t
no dhcpd enable inside
no dhcpd address 192.168.1.x-192.168.1.x inside
int vlan1
ip address 192.168.0.1 255.255.255.0
exit
wr mem

Substitute your current values for your DHCP pool in the above "no dhcpd address" command.

See if that does it...if you want to re-enable DHCP on the inside interface, you'll have to define a new DHCP pool on the 192.168.0.x network.  To put it back and enable it for use, use the following commands:

dhcpd address 192.168.0.x-192.168.0.x inside
dhcpd enable inside

Again, substitute whatever values you want to use for your DHCP pool in the above "dhcpd address" command.

Hope this helps...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
vturbaAuthor Commented:
Many thanks! I have to till monday before I can configure it. Keep you updated.
0
vturbaAuthor Commented:
doesn't work :(

By disabling the dhcp, I'll get the message;

"Interface address is not on same subnet as dhcp pool
ERROR: ip address command failed"
0
vturbaAuthor Commented:
Ok, deleting the dhcp pool is working, but when I'm want to change the ip adress, I receive a time out (because the computer wich is connected to the ASA, had got a IP in the range of 192.168.1.x )..
0
vturbaAuthor Commented:
He made a change, because I can connect the ASA with the new IP address, but I'll get the message "Unexpected end of file from server".. :/
0
vturbaAuthor Commented:
damn, I can't reach the ASA anymore :( :(
0
vturbaAuthor Commented:
Hmm, i fiixed it by the console with hyperterminal. ip changed with succes!! thanks all!
0
tourist08Commented:
This might be a little late but I wanted to add this in because I was going through the same thing when I tried to change the ASA's inside IP and subnet.  If you want to continue to use the ASDM gui interface do this.   Before you change the inside IP address use the start up wizard and go to step #12 and add in the new subnet your computers will be on because if you don't it will not allow any networks except those listed in the Administrative Access list to contact the ASA.  Also I"m not sure if you have to but I did any way is to create a new static route from the inside interface to the outside so you can get out.  Not sure if changing the ip of the interface would kill the route but I did it just to make sure, didn't test it though.  Well I hope this helps anyone that comes to this question.  
0
Steve_RogersCommented:
Thanks tourist08!  This was driving me crazy for days.  #12 worked great.
0
blaze2342Commented:
The problem is the launcher loses connection to the asa and does not get a chance to save the settings to the flash rom.  The asa will use the new settings until you reboot it.  So to make your changes permanent do the following:

1) load gui
2) go to configuration -> device access-> https/asdm
3) click add and add the new subnet
4) hit apply and save configuration
5) go to interfaces and change the router ip address and hit apply
6) let the gui geek out and force close the gui
7) change your local machine's ip address to the correct subnet and relaunch the gui
8) this time log in with the new ip
9) click save and you are good to go
10) dont forget to take your old subnet out of device access and set the new dhcp settings
0
PathFinder2Commented:
Just wanted to add this.  In ADSM if you go to File > Reset to factory defaults it will give you the option to change the default inside interface from 192.168.1.1 to whatever you want.  This corrects the above issue.
0
neo3998Commented:
pathfinder, brilliant suggestion - much quicker than the other options :)

Thanks

Neo3998
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.