BootMagic won't start after installation

Hi everyone,

The problem I have with my system is that after installing "Boot Magic V8" onto an XP Professional
system it now refuses to boot from the XP Pro primary drive. All that shows up after the POST check is something like "-." in the left corner above.

My motherboard is an Asus P5E3 DeLuxe WiFi-AP with one SATA Western Digital HD from 750 GB
I have created one C-partition from 100 Mb as FAT16 and one D-partition from 100 GB as NTFS for
my Windows XP Pro. BootMagic is installed on the C-drive.

I created the BootMagic Rescue disk, and when I boot from floppy it shows 1 OS that's already active,
so nothings seems wrong.

I have tried to boot up with fixmbr and fixboot, but nothing worked. Maybe there's a conflict between SATA-disk and BootMagic?

Everyting worked fine since installing BootMagic V8

Is there someone in the world who can solve this case???


Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

The problem with BootMagic/PartitionMagic is that Symantec has not released a single update to that program since they bought it from PowerQuest in 2003.  It's difficult to even find information about it from their web site.  It has a whole host of compatibility problems with Windows XP and today's enormous hard drives that Symantec has no plans to resolve.

When the program was last updated, 40GB hard drives were still common, with 120GB drives being the biggest available.  Hard to believe that was only 5 years ago.  Anyway, you likely have a bigger drive, and the program has just not been updated in so long that its support for 48-Bit LBA addressing is probably broken on modern hard drives.

Unfortunately, the hard truth is that you may well have fried the partition table.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial

I agree with cuziyg's comment that BootMagic has not been updated in years (a lifetime for software). However, I currently use BootMagic on many of my systems: XP, Server 2003 and dual-boot (XP/2K3).

The largest drive that I've installed it on is 320GB, though. So it may be the 750GB capacity that is causing the problem. But since it reports 1 OS when you boot from the floppy, I'd say that BootMagic is probably working fine.

You wrote that you created a C: and D: drive. Are trying to prepare the system for a new install of XP?

I believe that I can help you but it would help to know what disk utilities you have available. Do you have:
1. PartitionMagic or a similar program?
2. an MS DOS boot disk?

I generally use PartitionMagic to create 2 partitions:
Partition 1 ... Primary, FAT/FAT32, about 40MB.
Partition 2 ... Primary, NTFS, as large as you want for XP.
I then make Partition 2 'Hidden' and Partition1 'Active'

Boot using the MS Boot disk and then transfer the OS to C: by using the command     sys C:
This makes the C: drive bootable. Then I copy any files I want to have a minimal DOS environment (including CD/DVD drivers). I also copy other DOS-based utilities like BootMagic, PartitionMagic and Ghost (backup software).

At this point I can enable/configure BootMagic to display the DOS OS in it's menu. Once I know it is working I do the following:
1. add Partition 2 to BootMagic's menu.
2. make Partition 2 the default menu item.
3. disable BootMagic.
4. use the partition utility to make Partition1 'Hidden' and make that Partition2 is 'Active'. (This ensures that XP installation will not see the FAT/FAT32 partition.)
5. install XP
6. use the partition utility to make Partition 1 'Active' and Partition 2 'Hidden'
7. Boot up to the C: prompt and re-enable BootMagic.

I hope this helps.
MarcovdAuthor Commented:
Hi Guys,

Thanx for the possible resolutions :-)
I agree with cuziyq that PQMagic is not "up-to-date". My versionnumber of PQMagic is 8.0.5

So I have looked for another program and now I found Acronis OS Selector. This program
works perfect with my large disks, and I can boot multiple OS-es

So thanx for your input and all your help but I'am very satisfied now with Acronis

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
System Utilities

From novice to tech pro — start learning today.