ajax ScriptManager not being recognized

Getting the following error when switching to Design view of an asp page: The control with ID 'uprogMaster' requires a ScriptManager on the page.  The ScriptManager must appear before any controls that need it'.  The site actually appears to run fine but I can't view the page in design.
Masterpage.txt
webconfig.txt
LVL 1
bozworthyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bob LearnedCommented:
Did you find a solution?

Bob
0
bozworthyAuthor Commented:
No I haven't.  The error is still present but I've been able to continue developing.
0
Bob LearnedCommented:
That is because you don't have the prefix right for the control tool kit.

Change this line:

<%@ Register Assembly="AjaxControlToolkit" Namespace="AjaxControlToolkit" TagPrefix="ajaxToolkit" %>

to this:

<%@ Register Assembly="AjaxControlToolkit" Namespace="AjaxControlToolkit" TagPrefix="ajax" %>

Bob

0
Rowby Goren Makes an Impact on Screen and Online

Learn about longtime user Rowby Goren and his great contributions to the site. We explore his method for posing questions that are likely to yield a solution, and take a look at how his career transformed from a Hollywood writer to a website entrepreneur.

Bob LearnedCommented:
Change the 'ajaxToolkit' to 'ajax' to work with AJAX sample code, which usually uses 'ajax' as the prefix.

Bob
0
Bob LearnedCommented:
Actually, the ScriptManager is like this:

    <asp:ScriptManager id="ScriptManager1" runat="server" />

Also, if you are using a CSS style sheet, I would apply styles to the elements with CSS classes, instead of specifying the 'style' attribute.

Bob
0
bozworthyAuthor Commented:
I changed the scriptmanager tag, the register assembly declaration, and all control tags from
ajaxtoolkit to ajax.  (I don't think the <asp: is valid in the scriptmanager tag above)

<%@ Register Assembly="AjaxControlToolkit" Namespace="AjaxControlToolkit" TagPrefix="ajax" %>
<ajax:ScriptManager id="ScriptManager1" runat="server"/>

Still have the same problem.  I'm not going to monkey with the style attributes at this time.    
0
Bob LearnedCommented:
Here is a working example:


<%@ Master Language="C#" AutoEventWireup="true" CodeFile="MasterPage.master.cs" Inherits="MasterPage" %>
<%@ Register Assembly="AjaxControlToolkit" Namespace="AjaxControlToolkit" TagPrefix="ajax" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head id="Head1" runat="server">
    <title>Untitled Page</title>
</head>
<body>
    <form id="form2" runat="server">
            <asp:ScriptManager ID="ScriptManager1" runat="server" />
        &nbsp;&nbsp;
        <ajax:CascadingDropDown ID="CascadingDropDown1" runat="server" ServiceMethod="GetDropDownContents"
            UseContextKey="True">
        </ajax:CascadingDropDown>
    </form>
</body>
</html>

Open in new window

0
bozworthyAuthor Commented:
There is no <asp:ScriptManager> available to me.  Only <ajax:ScriptManager>.  My ajax installation/setup must hosed.
0
Bob LearnedCommented:
Attached my web.config file.  The big thing to note is this line:

<add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>

Bob
<?xml version="1.0"?>
<configuration>
	<configSections>
		<sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
			<sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
				<section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
				<sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
					<section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="Everywhere"/>
					<section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
					<section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
				</sectionGroup>
			</sectionGroup>
		</sectionGroup>
	</configSections>
	<system.web>
		<pages>
			<controls>
				<add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
			</controls>
		</pages>
		<compilation debug="true">
			<assemblies>
				<add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
				<add assembly="System.Web.Extensions.Design, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
				<add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
				<add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/></assemblies>
		</compilation>
		<httpHandlers>
			<remove verb="*" path="*.asmx"/>
			<add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
			<add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
			<add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>
		</httpHandlers>
		<httpModules>
			<add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
		</httpModules>
	</system.web>
	<system.webServer>
		<validation validateIntegratedModeConfiguration="false"/>
		<modules>
			<add name="ScriptModule" preCondition="integratedMode" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
		</modules>
		<handlers>
			<remove name="WebServiceHandlerFactory-Integrated"/>
			<add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
			<add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
			<add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
		</handlers>
	</system.webServer>
</configuration>

Open in new window

0
bozworthyAuthor Commented:
I made the change to web.config and the asp tag is accepted.  Still getting the error after moving the scriptmanager just above the updatepanel.

<asp:TableCell HorizontalAlign="left" Width="20%">
                        <asp:ScriptManager ID="smMaster" runat="server"></asp:ScriptManager>        
                        <asp:UpdateProgress ID="uprogMaster" runat="server" AssociatedUpdatePanelID="upMaster" Visible="true">
                            <ProgressTemplate>
                                <asp:Table ID="tblProgress" runat="server" Height="100%">
                                    <asp:TableRow>
                                        <asp:TableCell HorizontalAlign="left">
                                            <img alt="Now Loading" style=" background-color:Transparent;" src="Images/ajax-loader_bigroller.gif" />
                                        </asp:TableCell>
                                        <asp:TableCell HorizontalAlign="left">
                                            <asp:Label runat="server" ID="lblWait" ForeColor="white" Font-Bold="true" Text="Please Wait..."></asp:Label>
                                        </asp:TableCell>
                                    </asp:TableRow>
                                </asp:Table>
                            </ProgressTemplate>
                        </asp:UpdateProgress>
                    </asp:TableCell>        
0
Bob LearnedCommented:
I would try what I tried, and that is to create a new AJAX-enabled web site from the template, and paste that HTML into a new page, and see if it works, since it did for me.

Bob
0
bozworthyAuthor Commented:
Also every control on the content pages using that master page are now giving an error but the site still compiles with no errors and runs fine.  
0
bozworthyAuthor Commented:
I created a new AJax enabled web site.  Then added a master page and copied code from original site into it.  Then added a bin folder and placed AjaxControlToolKit.dll to the folder.  Still getting the same error about the updatepanel requiring a scriptmanager.

web.config:
<pages>
      <controls>
        <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
      </controls>
    </pages>

MasterPage.aspx:

<asp:ScriptManager ID="smMaster" runat="server" />
0
Bob LearnedCommented:
Funny, when I change Table to <table>, TableRow to <tr>, and TableCell to <td> it doesn't have that problem.

Bob
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bozworthyAuthor Commented:
yep that did it.  changed all the asp tables to html tables and the problem went away. thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP.NET

From novice to tech pro — start learning today.