Infopath 2003 form - Intranet asks for username and password when InfoPath form is opened.

Infopath 2003 form - Intranet asks for username and password when InfoPath form is opened.

I have an Intranet and on there I put a link to to an Infopath form (.xsn) however when I click on the link it asks for a username and password.

My profile (admin access) does not ask for this username/password
On most other profiles it does.
When I open the file directly from the network folder on the clients that have the problem with the intranet it opens up fine.

Could this be a permission problem?

Any help is appreciated.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Clay FoxDirector of Business IntegrationCommented:
InfoPath uses your Internet Explorer security.
Typically you want the site or server name that hosts the XSN to be in your Intranet or Trusted security zone.  This is under Internet options.  If it is a site you may need to look at the permissions in IIS and the folder permisions.  There is also a known issue with Vista where it does not cache your credential properly.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tsi_adminAuthor Commented:
Thanks for the response.

I added our intranet to the trusted site and had the same problem.
I played with permissions a bit but still came up with the same problem??
tsi_adminAuthor Commented:
I found the solution, when I was putting the link on my intranet, I noticed the system was putting the partial path. I changed it to put the full path \\servername\share\formname.xsn and it works perfect.

Thanks for your input.
Clay FoxDirector of Business IntegrationCommented:
I would think it must be a IIS permisions issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.