root startup needed to disable touchpad

this question is related to two questions i have asked

http://www.experts-exchange.com/Hardware/Peripherals/Mice_Keyboards/Q_22978082.htm

is the first question, where we managed to figure out how to disable the touchpad (beause
i have a USB mouse and touchpad is bad interference) by invoking a command on a terminal

it was done like this:

TeRReF:
If there is two entries, try this:

killall moused
moused -p /dev/ums0

later, i asked the follow up question:

http://www.experts-exchange.com/OS/Unix/BSD/FreeBSD/Q_23026627.html

and we figured out there

TeRReF:
Now that is weird. I specifically set the mouse port on USB and now your PS/2 mouse is working. What kind of laptop did you buy in gods name :-)

Can you try to comment out the three mouse related lines in /etc/rc.conf (just use a # in front of the lines)

Reboot and see if any of the mouse devices is working. If not, add this line in /etc/rc.conf:

usbmouse_enable="YES"

then type this:

echo "/usr/bin/killall moused ; /usr/sbin/moused -p /dev/ums0" > /usr/local/etc/rc.d/usbmouse

then type this:

chmod 555 /usr/local/etc/rc.d/usbmouse

now type this:

/usr/local/etc/rc.d/usbmouse

Is it working? If so, see if it works properly after a reboot...

TeRReF:
change this line:
echo "/usr/bin/killall moused ; /usr/sbin/moused -p /dev/ums0" > /usr/local/etc/rc.d/usbmouse

to
echo "/usr/bin/killall moused ; sleep 1 ; /usr/sbin/moused -p /dev/ums0" > /usr/local/etc/rc.d/usbmouse

TeRReF:
You need to do grep -i if you want to ignore case distinctions.

Try this, go to
System->Preferences->Sessions

THen the Startup Programs tab, the Add button and then add this one:
/usr/local/etc/rc.d/usbmouse

See if that works...

it did work.  the problem is, that at the time, i had the bad bad habit of typing into my gnome startup
login:

http://www.monkeyview.net/id/965/fsck/bioshd/p1100035.vhtml

that comes up right after startup, the first login  i do.. i would type "root" in there and log into
my gnome x window session as root.  every terminal i fired up was root, and browsers (not that
i would notice it) were all root.  i was told there was a strong possibility that graphics could
be trojan worms or whatever and this was a bad bad habit.  so i have run useradd and now
start up in gnome as a mere user.  

this seems to have run into a problem with respect to the moused.  maybe i don't have
adequate priviledges to run these moused things as a mere user.  will it be possible to
configure so that i can long in as a mere user and nonetheless my mouse automatically works
like i want it to work.
kayveyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TeRReFCommented:
Try this:

edit /etc/rc.conf

comment out this line:
gdm_enable="YES"

reboot. Gnome will not start. That's good in this case.

Now login as root and type:
killall moused

then type:
/usr/local/etc/rc.d/gdm start

and see if the mouse is working properly

If not check this file /etc/X11/xorg.conf

and look for the mouse section. Change the Device line into:
        Option      "Device" "/dev/ums0"

and reboot again to see if it works now
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kayveyAuthor Commented:
OMG OMG.  i should have written down "/etc/rc.conf"

i don't think that worked.  touchpad was going on character based menu. couldn't get
X back.  was i supposed to?

i made a typescript, but i'm at kinkos now... but i can remember.. umm.. yeah..

i think when i went to the /etc/X11 directory, there were a bunch of files there that we
were messing with.. like 4 files total.. umm.. xorg.conf was an empty file because i
tried vi-ing it, but there was also files like "xorg.conf.bak" or something i think i remember
saving those when you were getting all upity on me one time.

is it a real bad thing do just vi stuff all the time?  i vaguely remember in a sysadmin class
maybe that's not the way to do it.. sudo or something.. ferget.. oh.. sudo runs a specific
program with some sort of limitations?  i suppose there are things i haven't run into.. or
operating on running servers or something?

anyhoo.. i am going to get my gnome back up now.  sheeh.. this single user mode (or whatever
character based) i mean i used to always work this way, and i haven't totally updated to like
vim nonsense, although i have worked on like MS compilers with all that nice pretty code formatting
stuff, keyword in blue strings in green, etc or whatever.. but i am sort of in between having
a bare terminal and "21st century technology" these days.. i like lots of plain two color terminals
and lots of web browsers all running to keep me sane.
0
TeRReFCommented:
Well, if you type
:syntax on

in vim, you'll get nice colours too :-)

0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

kayveyAuthor Commented:
okay.. I'm a little afraid to proceed.  As I said in the above, it didn't seem to work.  I don't know why
the system obliterated my /etc/X11/xorg.conf file.  I just edited the file xorg.conf.bak2

Section "InputDevice"
        Identifier      "Mouse0"
        Driver          "synaptics"
        Option          "Protocol"              "auto"
        Option          "Device"                "/dev/ums0"
        Option          "Emulate3Buttons"       "on"
        Option          "ZAxisMapping"          "4 5"
        Option          "SHMConfig"             "on"
EndSection

I resisted pasting the whole thing in here.. but fear what else is in there.
0
TeRReFCommented:
Just try, you can always rename it again to get X going again...
0
kayveyAuthor Commented:
okay.. now this is crazy nutball.  it works right now, however...

[kayve@kv_bsd ~]$ ls /etc/X11
xorg.conf.bad   xorg.conf.bak   xorg.conf.off
[kayve@kv_bsd ~]$

as you can see, i had to "turn xorg.conf.off"

I took a picture.. let me upload that..

oh wait.. okay.. uploaded the pic.

now we've solved the problem ..

oh wait.. no we haven't..

arg.

never mind
p2030037.jpg
0
TeRReFCommented:
Do you have sshd running? In other words, can I login with SSH to your laptop?
0
kayveyAuthor Commented:
i dunno

kv_bsd#ps -aux | grep sshd
root    813  0.0  0.1  3524  1436  ??  Is   Mon06AM   0:00.00 /usr/sbin/sshd
root  67109  0.0  0.1  1592   872  p1  S+    1:29PM   0:00.00 grep sshd
kv_bsd#
0
TeRReFCommented:
Yeah, looks like it, you can try it by typing this:

ssh yourusername@localhost

If you get a password prompt, it's working. Usually root login via ssh is disabled, so you will have to use another valid user on the system.

If you want, I can login to your laptop and have a go at this problem. It's probably solved much faster and easier to explain what I did afterwards...
0
kayveyAuthor Commented:
but how will i learn anything then?

[kayve@kv_bsd ~]$ ssh kayve@localhost
The authenticity of host 'localhost (127.0.0.1)' can't be established.
DSA key fingerprint is cc:65:20:82:22:16:b5:11:5a:a8:cb:02:ff:d1:7b:73.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'localhost' (DSA) to the list of known hosts.
Password:
Last login: Mon Feb  4 06:38:23 2008
Copyright (c) 1980, 1983, 1986, 1988, 1990, 1991, 1993, 1994
        The Regents of the University of California.  All rights reserved.

FreeBSD 6.2-RELEASE (GENERIC) #0: Fri Jan 12 10:40:27 UTC 2007

Welcome to FreeBSD!

Before seeking technical support, please use the following resources:

o  Security advisories and updated errata information for all releases are
   at http://www.FreeBSD.org/releases/ - always consult the ERRATA section
   for your release first as it's updated frequently.

o  The Handbook and FAQ documents are at http://www.FreeBSD.org/ and,
   along with the mailing lists, can be searched by going to
   http://www.FreeBSD.org/search/.  If the doc distribution has
   been installed, they're also available formatted in /usr/share/doc.

If you still have a question or problem, please take the output of
`uname -a', along with any relevant error messages, and email it
as a question to the questions@FreeBSD.org mailing list.  If you are
unfamiliar with FreeBSD's directory layout, please refer to the hier(7)
manual page.  If you are not familiar with manual pages, type `man man'.

You may also use sysinstall(8) to re-enter the installation and
configuration utility.  Edit /etc/motd to change this login announcement.

[kayve@kv_bsd ~]$
0
TeRReFCommented:
The daemon is running. I will try to explain afterwards. But if you want to do it yourself it's fine too. Just go over all the questions you asked relating to this problem and follow the various steps I described there...

The Xorg -configure

and stuff...
0
kayveyAuthor Commented:
I'm scared to post a login shell here
0
TeRReFCommented:
You should never do that indeed. Always email it to me directly. See my profile for my email address...
0
kayveyAuthor Commented:
i suppose it is morning in netherlands..

arg.. i was feeling like powering down...
0
TeRReFCommented:
Correct, it was :-)
0
kayveyAuthor Commented:
so can i fix my authentication now?
0
TeRReFCommented:
Yes.
0
kayveyAuthor Commented:
2:36am in California right now.  Couldn't sleep.  Have an interview today I don't know what time.
0
kayveyAuthor Commented:
Okay my mouse isn't working right.  You did something?
0
TeRReFCommented:
No, I couldn't. I guess you didn't receive my last email since you added the above comment. I'll send it again tonight...
0
kayveyAuthor Commented:
otay
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Peripherals

From novice to tech pro — start learning today.