NTFS Permissions not being passed/inherited properly

Listed below is an examplpe of a file path in our file server.

C:\Data\Images\2008\January

Permissions in the 2008 folder are set to apply to "This folder, subfolders, files", and I selected replace permissions for child objects.

But when I go into the january folder, I can't open anything, I can't add anything, I can't do anything.  So I check the permission for the January, and low and behold all the permissions are set to apply to folder only.

Why is that? The january folder is set to inherit, so why is it not inheriting?  How can I fix it, short of manually going to the january folder and setting permissions manually?
orbitrodAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

chikenheadCommented:
sounds like the january folder is blocking inheritance, remove the inheritance blocking then go to the parent and redo the apply to child objects
0
reubstrCommented:
In the permissions > advanced tab, you may need to replace all child object permissions.
0
chikenheadCommented:
follow the inheritance chain up to the parent, one of the folders is blocking inheritance
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Matthew MillersCommented:
If the permissions that you rae apply are what you want for all subfolders, you can click the advanced button while on the security tab, then tick the option to replace permission entries on all child objects.
Please note - doing this will actually replace all the permissions -AND- it will reset the inherit permissions flags for ALL subfolders.
0
ChiefITCommented:
There are two types of inheretance in the advanced tab.

One is to pass down permissions to all child like objects.

The other is to inheret from the parent that passes down permissions to all child objects.

I think you have to go to the January file folder and allow it to inheret from the parent. Since this wasn't selected before, you may have to go to the 2003 folder and pass down permissions to all child objects again.  
0
ChiefITCommented:
Oops, Mattie has it right.

0
orbitrodAuthor Commented:
2008 was set to replace permissions, and I checked the January folder and it is also set to inherit from the parent

BTW the January folder is inheriting permissions from the 2008 folder
0
reubstrCommented:
Go deeper to the next folder and see if it is unchecked. When you do a replace all permissions, it should take a few minutes to do that with a visual telling you it is doing it.
0
orbitrodAuthor Commented:
I went deeper into the next folder and it is not inheriting permissions correctly, when I go to the advanced screen, I see that it is inheriting permissions from the 2008 folder, but permissions are set to apply to folder only.  But in the 2008 folder I set permission to to apply to "This folder, subfolders, files".

I keep checking replace when I am in the 2008 folder, and it does appear to propagate throughout the subfolders and files, with a visual indicator tell me so. But it doesn't seem to work.

The only way I can get the permissions to work properly is to disallow inheriting and set the permissions manually.
0
reubstrCommented:
My next step of advice is to take ownership.

Shouldn't have to do this as admin, but you are having unique problems. I would try that, say on one of the folders in Jan that you know is having the problem. Then, do the inheritance and replace.

Have you tried to break inheritance, do a "Copy" of the permissions when it asks, and tried to rebuild it after they were removed? Sometimes breaking a setting first, will allow it to re-apply correctly.
0
orbitrodAuthor Commented:
reubstr you were right, all I had to do was uncheck allow inheritance, then click apply.  Then check  allow inheritance again and then apply again.  Then all the inherited permissions from the parent folders will be applied.

Now my problem is that there thousands of folders that need this to be done.

According to this article, http://support.microsoft.com/kb/320246/en-us, a vbs script can be written to automate this process.

Can anyone help me with this script?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
reubstrCommented:
I am glad we figured out the original request. I am however, not a programmer.

reubstr
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.