New FTP site on IIS is accessible via command line but errors using Internet Explorer

I've created an FTP site with a virtual directory pointing to a folder on our file server.  The Web server is in the DMZ and the file server is on our protected LAN,   When I try to access the FTP site/folder in IE using the url ftp://x.x.x.x/outlet I get the authentication screen and then log in using /domain/username and their password. I then get "An error occurred opening the folder on the FTP server.  Make sure you have permission to access this folder. Details: 550/outlet/outlet: The system cannot find the file specified."  The folder name, virtual directory name and user all use 'outlet'.

I can access the site using my admin equivalent username.  I can also access the folder if I use a command line ftp session and use the outlet username.  I can log into a workstation as user outlet and use Windows Explorer to navigate to the folder and open a file.  Also, this is a duplicate of another FTP site I set up that seems to have no problems - but uses a different username for access.  Both users were created just for their respective FTP site's access.

So, why can't I get to ftp://x.x.x.x/outlet using IE and user outlet????
si-supportAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
si-supportConnect With a Mentor Author Commented:
OK.  I think I understand now.  I created another folder under the file server folder the virtual directory points to - call it outlet#2.  Now, when I ftp to x.x.x.x/outlet#2 it takes me to that folder no problem.  So, if I want people to connect to a specific folder in the URL, I just need to create that folder under the file server folder and place the content there.

I'm calling this one closed.
0
 
pcsmitpraCommented:
User account you are using must have permission on file server otherwise your webserver ftp account will not be able to access the files.
0
 
Sam PanwarSr. Server AdministratorCommented:
Hi,

It is look like permission issue so please check the user have sufficient permission on the folder to access of the file server.

Please also check in any ftp client like smartftp or cuteftp instead of the IE because sometime the ftp protocol ios not better work with the browser due to browser security setting.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
si-supportAuthor Commented:
The user has permission on the folder on the file server.  I can log into a pc as that user (outlet) and open the files in that folder.

I've found that if I change the Security Accounts setting in the Properties of the FTP site to 'Allow anonymous connections', I can connect to the site with no problem - without getting asked for authentication.  When I remove that check box, I get the error again.  And yet going to the Permissions setting on the FTP site in IIS and giving the 'outlet' user Full permissions doesn't change anything.  If it matters, the Properties of the Virtual Directory are set with the user 'outlet' credentials in Connect As.
0
 
si-supportAuthor Commented:
Addl info - I can connect using Filezilla FTP program and can connect at the command line using the ftp command and logging in with user credentials  'domain-name\outlet'.  Just not from the web browser using those same credentials.
0
 
si-supportAuthor Commented:
OK.  Now I have it to the point that when I use the browser and point it to the ip address (ftp://x.x.x.x), it allows me to log in and takes me directly to the contents of the 'outlet' folder on the server.  But, If I try to use the URL x.x.x.x/outlet to specify the Virtual Directory, I still get the original error message. And, if I create a new virtual directory for the same ftp site I cannot access it. The URL with just the ip address still goes to the original 'outlet' folder and if I specify the URL with the ip address and virtual directory, I get denied access.

Again, looking at the FTP site set up on this server long ago, I have to enter the ip address/virtual directory in the URL to get to the folder referenced by the Virtual Directory.  This is as I would expect it.  

So, how come I can't use the ip address/virtual directory name URL to access the folder?
0
All Courses

From novice to tech pro — start learning today.