can't receive incomming emails

hello,

I have installed a my first ( and the networks' first) exchange server 2003 w/ sp2.  It's installed on win2k3 standard, with all patches and updates applied.

the server is behind a netgear router with port forwarding enabled on port 25.  i also have the a domain registered with godaddy, and i made sure to add an MX record under the "Total DNS control" panel.

My issue is i can sent and receive emails with the network.  I can also send out emails to the outside world.  the issue is i can't receive any emails from the internet.  I tried to repy to my test message from different domains (hotmail, yahoo, and even my work email account), i always get a bounce back

here is the bounce back detail message:
Reporting-MTA: dns;bay0-omc2-s12.bay0.hotmail.com
Received-From-MTA: dns;BAY134-W33
Arrival-Date: Fri, 1 Feb 2008 15:12:28 -0800

Final-Recipient: rfc822;mshalabi@dareazon.com
Action: failed
Status: 5.5.0
Diagnostic-Code: smtp;553 sorry, relaying denied from your location [65.54.246.148] (#5.7.1)

any help would be greatly appriceated.
bloodywickedAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

millemaCommented:
Looks like a DNS problem with your public MX record.  You're not allowed to use CNAMES.
 
FAIL MX A lookups have no CNAMEs WARNING: One or more of your MX records points to a CNAME. CNAMEs are prohibited in MX records, according to RFC974, RFC1034 3.6.2, RFC1912 2.4, and RFC2181 10.3. The problem MX record(s) are:
smtp.secureserver.net.->smtp.where.secureserver.net.->208.109.80.149
 
0
bloodywickedAuthor Commented:
so, should i chance the mx record to "mail.mydomain.com" instead of just "mail" ... and if that's the case, how come i can still send out email messages to internet accounts !!
0
millemaCommented:
I think your primary problem is the permissions on your SMTP server.  It looks like you've disabled anonymous access.   Assuming you're using Exchange as your inbound SMTP server, select the properties for the server, go to the Access tab, click the Authentication button, then check the box for Anoymous access.  Otherwise anyone who sends your domain an email message will have to have a username and password configured.

You should still fix DNS.  Set the MX record for dareazon.com to be smtp.where.secureserver.net.  You'll also want to update the reverse DNS record for 64.202.166.12 to be smtp.where.secureserver.net instead of smtp.secureserver.net.  You can then create a CNAME for smtp.secureserver.net to point to smtp.where.secureserver.net.

These problems won't prevent sending mail out to the Internet, although some mail domains will reject the messages as suspected spam due to the DNS problems.
authentication.gif
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
isaman07Commented:
Your problem is as stated by millema, the anonymous access on your smtp server and actually you should only keep anonymous access on it and remove everything else. Anonymous access does not mean that you are a open relay, anonymous access to your smtp server means, that all other mail servers can talk to your exchange server without a username and password. YOu are not expecting over 5 milliom mail servers to have a username and password to communicate with your domain.
In the image above, leave only anonymous access.
Also fix your MX record to point to your firewalls ip address.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.