Router configuration

I have Cisco Wireless Router 871W. I want to configure it in next way:
WAN - receives IP from  DHCP.
LAN - all 4 ports - DHCP from range 192.168.239.200 - 192.168.239.220
Local router IP: 192.168.239.1
WiFi gets IP from same range 192.168.239.200 - 192.168.239.220 or other (not important)
And I want to be able to access WAN from LAN...
Most of the things I did, but routing is not working...
Thanks,
Dmitry
LVL 11
dimitryAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Darr247Commented:
When you run IPCONFIG from a cmd window on the LAN machines do the adapters getting a 192.168.239.2xx address from the router's DHCP server also show 192.168.239.1 as their default gateway?
0
dimitryAuthor Commented:
Darr247, yes, default gateway is set properly.
0
neos2k1Commented:
can you do a show run and post the output. you should  mask all the passwords before.  
0
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

naughtonCommented:
haev you set the interface nat status -
ip nat inside
ip nat outside

?
0
dimitryAuthor Commented:

show run
Building configuration...
 
Current configuration : 5413 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname krisik-cisco
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 debugging
logging console critical
enable secret 5 $1$.kbU$FGF9xvgjfou9pBs009yiy.
!
aaa new-model
!
aaa group server radius rad_eap
 server 192.168.239.210 auth-port 1812 acct-port 1813
!
aaa group server radius rad_mac
!
aaa group server radius rad_acct
!
aaa group server radius rad_admin
 server 192.168.239.210 auth-port 1812 acct-port 1813
!
aaa group server tacacs+ tac_admin
!
aaa group server radius rad_pmip
!
aaa group server radius dummy
!
aaa group server radius rad_eap1
 server 192.168.239.210 auth-port 1812 acct-port 1813
!
aaa authentication login eap_methods group rad_eap
aaa authentication login mac_methods local
aaa authentication login eap_methods1 group rad_eap1
group rad_pmip 
aaa accounting network acct_methods start-stop group rad_acct
!
aaa session-id common
!
resource policy
!
clock timezone PCTime -8
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
ip subnet-zero
no ip source-route
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.239.1 192.168.239.199
!
ip dhcp pool sdm-pool1
   import all
   network 192.168.239.0 255.255.255.0
   default-router 192.168.239.1 
!
!
ip tcp synwait-time 10
no ip bootp server
ip domain name krisik-cisco.com
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
crypto pki trustpoint TP-self-signed-4049170220
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-4049170220
 revocation-check none
 rsakeypair TP-self-signed-4049170220
!
!
crypto pki certificate chain TP-self-signed-4049170220
 certificate self-signed 01
  30820255 308201BE A0030201 02020101 300D0609 2A864886 F70D0101   
  ...
quit
username krisik privilege 15 secret 5
!
! 
!
bridge irb
!
!
interface FastEthernet0
!
interface FastEthernet1
!
!
interface FastEthernet3
!
interface FastEthernet4
 description $FW_OUTSIDE$$ES_WAN$
 ip address dhcp client-id FastEthernet4
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 duplex auto
 speed auto
!
interface Dot11Radio0
 no ip address
 !
 broadcast-key change 600
 !
 !
 encryption mode ciphers tkip 
 !
 ssid cisco-wpa
 eap_methods1 
    authentication key-management wpa
    authentication client username krisik password 7 060D1D285F4702
    guest-mode
    infrastructure-ssid optional
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
 54.0
 station-role root
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$
 no ip address
 ip tcp adjust-mss 1452
 bridge-group 1
!
interface BVI1
 description $ES_LAN$
 ip address 192.168.239.1 255.255.255.0
 ip tcp adjust-mss 1412
!
 ip route 0.0.0.0 0.0.0.0 FastEthernet4
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
logging trap debugging
no cdp run
radius-server local
  nas 192.168.239.210 key 7 060A2F335E57
  user krisik nthash 7 1248233240285B507209760E11630743214E51500E0A7C0A015825494
00B0F7670
!
radius-server attribute 32 include-in-access-req format %h
radius-server host 192.168.239.210 auth-port 1812 acct-port 1813 key 7 151E2B1E1
633
radius-server vsa send accounting
!
control-plane
!
bridge 1 protocol ieee
 banner login ^CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
 no modem enable
 transport output telnet
line aux 0
 transport output telnet
line vty 0 4
 privilege level 15
 transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end

Open in new window

0
dimitryAuthor Commented:
to naughton,
No I didn't touch NAT. But why should I change it ? I didn't want to access internal LAN from outside.
Or in cisco routers you need to set up NAT to go outside as well ?
0
naughtonCommented:
the error is in your NAT configuration.  you need to specify the inside and outside interfaces so that the traffic can eiother be pat's or nat'd depending on you peticular configiguration.  the logic is that you have a single outside ip, and you have 20 ip's using it.
0
dimitryAuthor Commented:
naughton, you are probably right. But I need more detailed explanation how to set this NAT... :)
0
naughtonCommented:
conf t
int fe4
ip nat outside
exit
int bvi1
ip nat inside
exit
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dimitryAuthor Commented:
It passed but it didn't help. Do I need to save it somehow ?
0
naughtonCommented:
when you ran the wireless configuration - did you set it to bridge or to route?
0
dimitryAuthor Commented:
I think I set it to route - at least it was my intention.
0
naughtonCommented:
change it to bridge.
0
dimitryAuthor Commented:
Can somebody give me please the whole sequence of configuring what I've asked ?
0
naughtonCommented:
hey dimitry,  did you sort this or do you stillneed assistance?
0
dimitryAuthor Commented:
Hi,
No it still doesn't work - I can access AP from WiFi and from LAN, but LAN doesn't see WiFi and WiFi doesn't see the LAN.
0
Darr247Commented:
It looks to me like you've made another vlan that's totally different than vlan1/bvi1, and I don't see where the ethernet ports are set to use any of them.

As much work as you've already put into it, I would still recommend wiping it and starting fresh.
Check out this excel file http://downloads.techrepublic.com.com/download.aspx?docid=243375

It has descriptions of what each command does in the next cell over.
If you enable macros you can put your settings in on the Variables tab, then click Replace and it will copy them all to the appropriate fields. You can then paste them in a few lines at a time...
See the whole tutorial at http://articles.techrepublic.com.com/5100-1035-6102399.html

It demonstrates setting up:
Stateful packet inspection firewall
Two virtual Wireless LANs (max 10)
Two virtual LANs bridged to the two wireless LANs
Both Wireless LANs configured for WPA security
One virtual LAN serving as a guest network with restricted access
DSL PPPoE client
DHCP server
Four-port VLAN-capable switch configured to support 2 separate networks

Ignore the DSL PPPoE section if you don't need that, but I'm pretty sure the rest of it will help... the excel file looks especially handy. Be aware there may be errors in it (that I almost think they put in on purpose to make sure you learn something from the tutorial).
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Hardware

From novice to tech pro — start learning today.