How do I correct the Act Address Book configuration in Outlook 2007

I am having a problem with my Act! 2008 and Outlook 2007 not wanting to cooperate.  When I open Outlook, I receive the error message - "The ACT! Address Book service is not properly configured, or the configured database [my database name] is locked. Do you want to configure it now?

This seemed to begin occurring about a month ago after I performed a repair/reinstall of Act!, due to some odd behavior with Act's performance.  Now Act! runs pretty clean and fast, but the relationship with Outlook is 'broken'.

I have tried the suggested fixes that I have read in earlier discussions - disabling Windows firewall, McAfee firewall, UAC... no luck.  I have unattached/reattached the Act address book in Outlook... no luck.

I would appreciate any additional ideas that someone may have.
mmontonaraAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mike LazarusAct! Evangelist - CRM ConsultantCommented:
When you did the repair/reinstall of ACT!, did you maybe change username or password?

Check this article  - http://tinyurl.com/2gzy6w
0
mmontonaraAuthor Commented:
Thanks for the fast response.  I did not change the username or password.  But, I just went back again to detach and reattach the address book to double check the logins, and I get the following:
- I detached the Act address book and closed Outlook.
- I reopened Outlook, without receiving an error message
- I go back into Account Settings to reattach the Act Address book
- After selecting to add an Act Address book it gives me the message - "The E-Mail Account you have just added will not start until you choose Exit from the File menu, and then restart Microsoft Office Outlook."  There is no login dialogue box.
-  If I click on the Act Address book to change it, I get the following error message: "An unknown error occurred, error code: 0x80040154"

When I close and then re-open Outlook, the old error message returns, "The Act! Address Book service is not properly configured,..."
0
Mike LazarusAct! Evangelist - CRM ConsultantCommented:
Try detaching it again and using the dialog in ACT! - Tools | Preferences to recreate it.

Failing that, try a Detect and Repair in Outlook or a reinstall of .Net as per - http://tinyurl.com/2cn4hh
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

mmontonaraAuthor Commented:
I was unsuccessful in detaching/reattaching through Act.  I looked up the .net installs.  I have 1.1 and a 1.1 hotfix (kB929729).  I don't have 2.0 indicated as installed.  A couple of weeks ago, after this problem started, I thought that this might be a problem area.  I did not see .Net 2.0 installed.  So, I went to the internet to download a redistributable copy of 2.0.  When I tried to install it, it said that it was already installed.  But, it is not listed in the programs list.

After that, I downloaded 3.0 redistributable and installed.  That did not fix the problem.  And I have tried to uninstall that 3.0 version, but the program list does not give me an uninstall option for it.  So, I turned it off through the options.

How would I find and uninstall 2.0 if that is causing the problem?
Thanks again for the assist.
0
Mike LazarusAct! Evangelist - CRM ConsultantCommented:
What happened when you tried to re-create it from ACT!'s Preferences?

Ouch... you really shouldn't have all those .Net versions unless you have an application using them.
ACT! 2008 will only use 2.0

To get the cleanest install of ACT!, I suggest you try these steps of mine:

"      Uninstall any version of ACT! from Windows Control Panel
"      Use the Uninstaller.exe from the ACT! KB 19338
"      Uninstall .Net Framework (all versions).. if any app uses another version, you can install it later
"      Uninstall MS SQL from Windows Control Panel if it's still there
"      Uninstall MSXML Services from Windows Control Panel if it's still there
"      Perform a Selective restart with MSCONFIG as per ACT! KB 14499
"      Install .Net 2.0 Framework from MS web site - http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en
"      Manually install MS SQL as per ACT! KB 19386
"      Install ACT! 10
"      Restore from Selective Startup Mode with MSCONFIG
"      Reboot
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mmontonaraAuthor Commented:
What a process!  But, it worked.  Two quick notes - I am running 32bit Vista.  When I tried to re-install .net 2, I got a message that said it was already installed and a part of the base operating system.  Second, when I re-installed MS SQL, I got an error with sqlncli.msi not being found.  I found a solution online for locating this file in the install file, uninstalling it, before trying to re-install MS SQL.
Thanks for the help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.