Multiple Site VLAN Connectivity help

I have 4 cataylst 3550 switches with an L3 IOS recently installed.

These 4 switches are to be used at different sites connected via Telewest National Ethernet circuits.

I understand how to configure this by configuring L3 ports; however, I want to use VLANs and I am not sure how to use VLANs in this setup. I understand the use of VLANs with L2 switches using an L3 switch or Router to route between the VLANs.

Two of the 3550s will be located at HQ and one at each of the other two sites, example:

-      HQ1 and HQ2 connected directly to one another.
-      Office1 connected directly to HQ1
-      Office2 connected directly to HQ2

I only want one port from each switch used to interconnect them together, the other ports will be in the same VLAN to connect to the local LAN.

The main point I do not understand is how can you create a VLAN between two point to point links (switch to switch) without assigning an IP address to the interfaces? Also how routing would work as I am unsure if I can use EIGRP in a pure VLAN environment.

If you could provide a high level list of what I need to do to create this environment it would be much appreciated. I can provide more info if required.

Thanks.
Nael_ShahidAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jonmckinlayCommented:
are you planning on using 1 vlan per site?  

You can use EIGRP, what you would need to do is to have 1 (or more) vlans per site, then 4 point-point subnets (30 bit masks) to use for the routed interfaces. The important thing to note is that the vlans do not matter over the layer3 links, what you will have is 1 vlan per subnet.

example, I have used different vlan for each site just to illustrate point, I'm also assuming you have other switches downstream from the layer 3 ones.

HQ1
int Vlan 10
  ip add 10.10.0.254 255.255.255.0
int f0/3
  desc Local Switches
int f0/1
  desc WAN Circuit to HQ2
  ip add 10.0.0.1 255.255.255.252
int f0/2
  desc WAN Circuit to Office1
  ip add 10.0.0.5 255.255.255.252
router eigrp 1
  network 10.0.0.0
  no auto-summary

HQ1
int Vlan 11
  ip add 10.11.0.254 255.255.255.0
int f0/3
  desc Local Switches
int f0/1
  desc WAN Circuit to HQ1
  ip add 10.0.0.2 255.255.255.252
int f0/2
  desc WAN Circuit to Office2
  ip add 10.0.0.7 255.255.255.252
router eigrp 1
  network 10.0.0.0
  no auto-summary

Office1
int Vlan 12
  ip add 10.12.0.254 255.255.255.0
int f0/3
  desc Local Switches
int f0/1
  desc WAN Circuit to HQ1
  ip add 10.0.0.6 255.255.255.252
router eigrp 1
  network 10.0.0.0
  no auto-summary

Office2
int Vlan 14
  ip add 10.14.0.254 255.255.255.0
int f0/3
  desc Local Switches
int f0/1
  desc WAN Circuit to HQ2
  ip add 10.0.0.8 255.255.255.252
router eigrp 1
  network 10.0.0.0
  no auto-summary


Hope this helps.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jonmckinlayCommented:
for resilliace you could also complete the WAN with a link from office 1 to office 2.  This way if HQ1-2 goes down you don't have your network split in 2!!
0
Nael_ShahidAuthor Commented:
I am planning 1 vlan per site.

Thanks for your response. I have diagramed a network with this to help me get my head around it and I will get back to you asap.

One quick question, can you route from a vlan (L2 interface) to a L3 interface (subnet) on the same switch?

Thanks again...
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Nael_ShahidAuthor Commented:
Hi

Forget the above question. I am sure you can route from a vlan to an L3 subnet otherwise you wouldn't have configured the network this way.

On your example you have F0/3 connected to local switches. I assume F0/3 needs to placed in the corresponding vlan? ie:
-------------------------------
HQ1
int f0/3
switchport access vlan 10
--------------------------------
Could I have multipul ports (connected to other local switches) in the same vlan with them all in the same subnet? IE:
--------------------------------
HQ1
int range f0/4 - 8
switchport access vlan 10
--------------------------------
Ports F0/3 to 0/8 in vlan 10 (10.10.0.0/24) with a gateway of 10.10.0.254??
0
Don JohnstonInstructorCommented:
Since each site will have it's own VLAN, there's no need to transport VLANs over the point-to-point links. I would suggest layer-3 interfaces for site-to-site connections and layer-2 interfaces within each site.

For example:
HQ1
vlan 10
interface f0/1
 description link to office 1
 no switchport
 ip address 192.168.1.1 255.255.255.252
interface-range f0/2 -24
 switchport
 switchport mode access
 switchport access vlan 10
interface vlan 10
 ip address 192.168.10.1 255.255.255.0
router eigrp 1
 network 192.168.1.0
 network 192.168.10.0
 no auto-summary
 
HQ2
vlan 10
interface f0/1
 description link to office 2
 no switchport
 ip address 192.168.1.5 255.255.255.252
interface-range f0/2 -24
 switchport
 switchport mode access
 switchport access vlan 10
interface vlan 10
 ip address 192.168.10.2 255.255.255.0
router eigrp 1
 network 192.168.1.0
 network 192.168.10.0
 no auto-summary
 
Office1
vlan 100
interface f0/1
 description link to HQ 1
 no switchport
 ip address 192.168.1.2 255.255.255.252
interface-range f0/2 -24
 switchport
 switchport mode access
 switchport access vlan 10
interface vlan 100
 ip address 192.168.100.1 255.255.255.0
router eigrp 1
 network 192.168.1.0
 network 192.168.100.0
 no auto-summary
 
Office2
vlan 200
interface f0/1
 description link to HQ 2
 no switchport
 ip address 192.168.1.6 255.255.255.252
interface-range f0/2 -24
 switchport
 switchport mode access
 switchport access vlan 200
interface vlan 200
 ip address 192.168.200.1 255.255.255.0
router eigrp 1
 network 192.168.1.0
 network 192.168.200.0
 no auto-summary

Open in new window

0
jonmckinlayCommented:
Hi Nael,

Yes you are correct about the switchport access vlan xx on the local interfaces, sorry I missed that out!
You can also have multiple ports in the same vlan as described in the int range command above, if the 3550's were gigabit ports you may want to connect any servers you have local on site directly into the 3550 and then other switches for the user access on the other gigabit ports.

If you are adding other cisco switches you may want to do the interfaces between the switches as trunk ports, just incase you need to add additional vlans in the future.

hope this clarifies.
0
Nael_ShahidAuthor Commented:
Many thanks for your help jonmckinlay; this is exactly what I needed.

Donjohnston, thanks for you input also but jonmckinlay answered first so it would be unfair not to give him the points.

I'm sure I'll be back for more help soon as I am rather new to Cisco.

Thanks again, both of you.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Architecture

From novice to tech pro — start learning today.