How do I recover data from a DOS hard drive?

I have successfully removed the hard drive from an Everex Tempo LX  laptop from June/1991, and slaved it to a Win XP PC.  I can see the drive in the BIOS and Device Manager: Conner Periipherals 63MB - CP2064.  However, I do not see it in My Computer or Disk Management, where I could assign it a drive letter.  I'm sure it has to do with the file system not being able to be read by Win XP / NTFS.  I don't know what file system it is.  The laptop was running DOS.  Any further ideas on how to get data off there that could then be read by Windows would be greatly appreciated.  Thank you very much for you help.
marathonman330Asked:
Who is Participating?
 
Lee W, MVPConnect With a Mentor Technology and Business Process AdvisorCommented:
The file system has nothing to do with it.  DOS uses FAT16 - that's about as universally supported a file system as there is.  Every version of Windows supports it... and most smaller USB Flash drives still use it.

Even if the file system was unreadable, the drive should appear in Disk Management indicating the partitions were in an "Unrecognized File System".

It sounds very much like the drive is bad... you can try it in another system, but if you want the data off it, you may well be stuck sending it to a Data Recovery service.
0
 
johnb6767Commented:
If Disk Management doesnt see it, does the Device Manager?

If not, then Data recovery software probably wont work...

0
 
johnb6767Connect With a Mentor Commented:
These are a few good recovery apps. Just pull this other drive out, and slave it to an available machine, and let the scans run... Most apps you can scan for free, and purchase the license if it is successfull. I find the Paid apps are more reliable....

Paid apps...

EasyRecovery DataRecovery - Trial Edition
http://www.ontrackdatarecovery.com/include/document.asp?file=http://download.ontrack.com/freedownloads/erdrt_610.exe

GetDataBack for NTFS V3.32 Data Recovery Software
http://runtime.org/gdbnt.zip

GetDataBack for FAT V3.32
http://runtime.org/gdb.zip

Spinrite v6.0
http://www.grc.com/sr/spinrite.htm

Active@ UNDELETE Recover deleted files on NTFS FAT32. Data ...
http://www.active-undelete.com/

Free utilites

PC Inspector File Recovery - Credit nobus for this link
http://www.pcworld.com/downloads/file/fid,23069-order,1-page,1-c,utilities/description.html#

Restoration
http://www.pcworld.com/downloads/file/fid,23108-order,1-page,1-c,filemanagement/description.html

FreeUndelete
http://www.officerecovery.com/freeundelete/

And accessing the recovered files, you might need to take ownership of the files to gain access....

How to take ownership of a file or folder in Windows XP
http://support.microsoft.com/kb/308421
0
[Webinar] Improve your customer journey

A positive customer journey is important in attracting and retaining business. To improve this experience, you can use Google Maps APIs to increase checkout conversions, boost user engagement, and optimize order fulfillment. Learn how in this webinar presented by Dito.

 
Pétur Ingi EgilssonSoftware Engineer -- ConsultantCommented:
That drive is old.. it might have jumpers on it, if so .. move them to CS ( Cable Select ) and see if it does the trick.
refer to : http://www.pcguide.com/byop/byop_SettingHardDriveJumpers.htm : for information about Jumpers.

Another option might be.. your using a ATA133 cable for that old ATA33? drive.
Try to dig up an older cable.
0
 
moorhouselondonCommented:
The other gotcha is if the drive has had OnTrack's Disk Manager (DM) or Stac disk compression software installed upon it.  If it is Disk Manager then there will probably be images of the DM floppy floating around on the web.  DM was an off the shelf retail product, but OnTrack produced OEM versions for free - so look out for the Conner-badged version.  
0
 
marathonman330Author Commented:
Thank you for your help.  I would like to try the jumpers first.  I found the below documentation by googling Conner Periipherals 63MB - CP2064.  I know I can try trial and error but was wondering if anyone could make sense of this and tell me which is the slave setting.  Apparently there is no CS setting.

FIGURE CONNER-3
------------------------------------------------------------------------
|   CONNECTOR:                                    |_+5V Power          |


                                   Page 55
|   X X   X X X X X X X X X   X X X X X X X X X X 5 X                  |
|   X X   1 X X X X X X X X X X X X X X X X X X X 5 G                  |
| ==R R========PCBA===============================|=n===               |
|   s s   |                                       | d                  |
|   v v   Pin 1                                   |                    |
|   d d                                           |_+5V Power          |
------------------------------------------------------------------------
                                     Single Drive   Master  Slave
                                     -------------|--------|-------
                                        E1 in       E1 in    E1 out
    -------------------------------
    | I |                         |
    | O |                         |
    |   |                         |
    | C |        PCBA             |
    | o |                  X X    |
    | n |                  X X    |
    | n |                  E E    |
    | . |                  2 1    |
    -------------------------------
0
 
MarkCommented:
Here is a good link showing the hard drive with jumper placement and such.
http://www.computerhope.com/hdd/hdd0029.htm
(Computerhope was the site that first helped me many years ago, very nostalgic seeing it again)
0
 
MarkCommented:
It looks as if the master/slave jumpers are on the bottom of the drive and the jumpers should be removed from the C D pins to put it in slave mode
0
 
Gary CaseConnect With a Mentor RetiredCommented:
First and MOST IMPORTANT thing to remember:  Do NOTHING that may write to the drive ... that's the first rule of data recovery; and you shouldn't have to write anything to this drive.

Second, I would attach this drive to its own IDE channel ==> jumper it as Single/Master (jumper C & D together) and use your secondary IDE channel [temporarily disconnect the optical drives].   [Sparkmaker: Nice link for the jumpers :)]

Try that and see if Disk Management picks up the drive.

An alternative would be to simply connect the drive with one of these very-handy-to-have gadgets:
http://www.buyextras.com/sausb20toide.html
0
 
nobusCommented:
you can also run from a live knoppix cd, and see if it can read it :
ftp://ftp.uni-kl.de/pub/linux/knoppix/KNOPPIX_V5.1.0CD-2006-12-30-EN.iso

and just to be sure, test it :  http://www.tacktech.com/display.cfm?ttid=287      
it can be bad...
0
 
MarkCommented:
Hey Gary, used to love computerhope when I first started into this PC fixing thing.  Google wasn't what it is today back then, and finding this link on their site put a smile on my face for sure.



For all in the know-->E.I.E.I.O.
0
 
marathonman330Author Commented:
I attached the drive to it's own IDE channel.  Disk Mgmt still did not see it but GetDataBack did.  I then tried data recovery but it found all sectors bad.  I then tried to confirm the hard drive is bad by running the Hitachi DFT but it didn't go anywhere.  My conclusion is the drive is bad and we have decided it is too expensive to send to a data recovery service.  Thank you for your help.
0
 
MarkCommented:
I guess my link didn't help??
0
 
marathonman330Author Commented:
sparkmaker:

Thank you for your help but, after attaching the drive as a master on it's own IDE channel, I saw no need to mess with jumpers.  The drive didn't have a jumper on it.  It must be master by default.
0
All Courses

From novice to tech pro — start learning today.