Java RE wont install (error 1722) + Time/Date stamp failure

Hi folks,

First post here so I hope you can get me off to a good start! ;-)

I'm trying to get Java RE installed on my new Vista (Home Premium) PC.   My browser is Firefox BTW.
 
I've tried offline installations, online and various versions of Java but it always fails towards the end of the installation process.

I get the usual 1722 error message:
"There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor."

However, perhaps more interestingly, I also get the following message prior to the 1722 message:
"Failure setting file's Time/Date stamp"

To try and overcome the installation problems, I've:
  tried various versions of the Java RE file
  run the .msi file from within my user profile
  turned off Vista's User Account Control feature
  tried installing to a custom directory

I've run out of ideas so would really appreciate some help.

Thanks in advance.




BabyFaceLimaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LeeTutorretiredCommented:
This web page has some more possible things to try:

http://forum.java.sun.com/thread.jspa?threadID=5201514
Java Runtime Environment (JRE) - Vista Home Premium - Unable to install JRE    

and another idea:

http://www.howtogeek.com/forum/topic/java-install-vista
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BabyFaceLimaAuthor Commented:
Thanks very much.  All is now fixed and working!  I'll post a reply to my question detailing exactly what worked for me.
0
BabyFaceLimaAuthor Commented:
Many thanks for the links Lee, you're a star!

Here's the solution that worked for me:

Some of these steps I'd already tried but in combination, this worked.  Whether all elements of this solution are required is another matter!

Removed any Java folders remaining from previous attempts
Ran Registry Mechanic to clean up registry
Disconnected from the internet
Disabled the following within Norton Internet Security: **
    Auto-protect
    Personal Firewall
    Intrusion Prevention
    Spyware Protection
Located and ran the .msi file within Users\$YourProfileName$\AppData\LocalLow\Sun\Java\jre1.6.0_04\
Et voila!!!

** in case you're not sure how to do this:
Open the Norton Protection Centre and click on the Norton Internet Security tab
Click on the (blue) Settings heading, select AutoProtect and Turn Off for a few minutes
Do the same for the three items under Web Browsing.




0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.