[Webinar] Streamline your web hosting managementRegister Today

x
?
Solved

Cannot create or copy files to a Windows 2003 Server folder but can create folders

Posted on 2008-02-03
22
Medium Priority
?
647 Views
Last Modified: 2013-12-04
I connect from my home office from an Apple Leopard system to a Windows 2003 Server Standard Edition through a VPN connection.  I am using the windows 2003 built in VPN function and have no problem accessing the server using my logon credentials as per my user in active directory.  Once the session is established, in the Apple finder I click on "Go" and then on "Connect to Server...".  Here I type in smb://IP Address of the Server/Network Data/ and click Connect.  Now come up all of my files that I have created at the office using my PC.  I can now copy any files from the Server that I am connected to remotely to my Apple Computer and I can also create folders on the Server while being connected to it remotely.  Here comes the issue, I cannot copy files from my Apple computer to the Server. I get an error message that states "The operation cannot be completed because you do not have sufficient privileges for some of the items".  A file on the Server is created with 0KB.  If I try to create a folder through it works without errors.  If I now try to copy files into this folder I also get the previous error message.  I've tried creating a new share and given it full access rights using the everyone group but still I am unable to copy files from my Apple machine using Leopard to the Server.  What am I missing?
0
Comment
Question by:Lounger-Master
  • 10
  • 7
  • 5
22 Comments
 
LVL 2

Expert Comment

by:bundas
ID: 20812902
If you make a folder inside another folder (or directory), you should give the permission since the parent directory. Maybe you forget to set the permission in the parent directory.
0
 

Author Comment

by:Lounger-Master
ID: 20819960
Hello Bundas

I tried this before and again now but no luck.  The folders are set to inherit permissions from the parent folder.  If I use a Windows machine to test the permissions it works without problems.  Further thoughts ?
0
 
LVL 2

Expert Comment

by:bundas
ID: 20862085
You might have the permission of read, but not write. Check on it.
Or, do you have firewall?
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 

Author Comment

by:Lounger-Master
ID: 20862489
The permissions are currently set to Full Control.
0
 
LVL 2

Expert Comment

by:bundas
ID: 20864454
No firewall?
0
 

Author Comment

by:Lounger-Master
ID: 20864596
My apologies, the firewall is just a Router.  It's a Linksys RV042 Router, thats it.
0
 
LVL 2

Expert Comment

by:bundas
ID: 20866352
Windows Server 2003 has it default firewall. Find it in the Control Panel
0
 

Author Comment

by:Lounger-Master
ID: 20869698
When starting the Windows Firewall I get a message that says "Windows Firewall cannot run because another program or service is running that might use the network address translation component (Ipnat.sys)."  FYI, connecting to the Server via VPN on a Windows machine casues no problems.

Thank You
0
 
LVL 2

Expert Comment

by:bundas
ID: 20873562
OK,the windows firewall is disabled if you have RRAS or another firewall.
By the way, your router has firewall. Did you check the setting?
0
 

Author Comment

by:Lounger-Master
ID: 20882013
The router firewall was on.  I've tried disabling everyhting but also no difference.  RRAS ?
0
 
LVL 2

Expert Comment

by:bundas
ID: 20882378
The router has default firewall. Usually the default of any firewall is set to allow you read and copy but not write.
Don't disable the firewall, but change the setting.
I don't have experience with  that kind of router. Maybe you can read it in the user guide in this site
http://www.linksys.com/servlet/Satellite?childpagename=US%2FLayout&packedargs=c%3DL_Product_C2%26cid%3D1115416833192&pagename=Linksys%2FCommon%2FVisitorWrapper
0
 

Author Comment

by:Lounger-Master
ID: 21011537
I just got back into town from a business trip.  My apologies about the delays.  I've searched high and low in the router and the manual for any type of read/write setting for the firewall but there is nothing.  If it was a firewall issue, shouldn't this be happening when a windows client connects via VPN?   It doesn't.  It is only when connecting from the Apple Leopard system.  Any other suggestions ?
0
 
LVL 2

Expert Comment

by:bundas
ID: 21012031
I was sure that it is a firewall problem, since the symptom of can read/copy but can't write is a default setting of every firewall in common.  I read in the user gude that your router has a firewall setting (i.e. see page 28) as the common VPN router. But if it is only happened from Apple Leopard system, I am sorry, it might be from your Apple Leopard system side.
(Maybe you can make sure, using Windows to connect the Server from your home office.)
Frankly speaking, I don't have any idea with Apple system. Basically there should be no problem with ALeopard - Windows.
Sorry for this long discussion. Maybe the expert of Apple Leopard can help.
0
 

Author Comment

by:Lounger-Master
ID: 21138871
No problem, thanks for your attempts regardless : )
0
 
LVL 1

Expert Comment

by:aaron63
ID: 21176856
We have the same problem, by the way. I don't think it is a firewall issue because the Mac computer is connected to the network via Linksys switches. All other computers are able to read/write fine...but the new Mac computer (which the user just HAD to have) has the exact same errors as the author described. Lounger-Master: If you've found a solution please post it here.

Thank you.
0
 
LVL 1

Expert Comment

by:aaron63
ID: 21176883
Possible solution here on Expert Exchange:

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Q_22613679.html

I'm trying to now...
0
 

Author Comment

by:Lounger-Master
ID: 21176998
Hello Aaron 63

The plot thickens.  I have just started on another company that has a Windows 2003 Server also.  I've set the entire system up from scratch and have actually found a work around.  It's not optimal but it works.  If you have a Word file for example that you have created on the Apple computer, open it, choose the save as option and now browse to the folder on the server.  When one clicks save, the file actually copies over to the Server.  Yes its a pain but it works.  I bet this is a possible Leopard bug.  Please keep me posted if you find out anything else.  Thank You.
0
 
LVL 1

Expert Comment

by:aaron63
ID: 21177203
I'm not an IT guru btw. I am just 'the guy' at the office who gets to deal with this stuff since I knew a thing about computers networking 10+ years ago. And I've never owned or worked on a Mac as my main computer. So I'm the proverbial monkey banging away at the keyboard until I get something that might work so I can focus on my 'real job'. :)

I won't be back to the office until Monday, but I've found several things to try and get it to work. I'll post results here.
0
 

Author Comment

by:Lounger-Master
ID: 21177458
The sad part is that I am the IT guru with over 24 years of experience.  Yes, please keep me posted if you find something that works.  Enjoy your weekend!
0
 
LVL 1

Expert Comment

by:aaron63
ID: 21216175
Okay I trried changing the ownership properties on the 2000 Server as suggested in the other Expert Exchange Thread (Folder-rightclick->properties->security->advanced->owner->replace owner on subcontainer and object->OK.

For me it didn't work. We still have the same problem. The user can copy from the Windows 2000 server but cannot copy files back (creates a 0 KB file).

Very frustrating.
0
 
LVL 1

Accepted Solution

by:
aaron63 earned 2000 total points
ID: 21217543
Success!!!!

Okay we found this on an Apple Forum:

Solution: On Windows 2003 Server, change the follo9wing policy:
From "Administrative Tools", open "Domain Controller Security Settings".
Go to "Local Policies" then "Security Options".

Scroll down to find the entry "Microsoft network server: Digitally sign communications (always)". Set this to "Disabled".

To use this policy setting immediately Run the following command: "gpupdate"

That worked for us. Now we don't have a problem copying files anymore. Sort of annoying that you have to change a server setting that has been default for some time. You'd think Apple would want to make connecting to a SMB 2003 server a no brainer.
0
 

Author Comment

by:Lounger-Master
ID: 21235753
Hello Aaron63

Wonderful, apparently the Apple system requires some of the same settings that a true DOS system would require.  I am hoping Apple will fix this with a patch.  Thank You so much!
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We could spend the next millennium discussing the differences of the Mac and Windows platforms. The next century will continue to have fanatics on both side of the equation and neither side will win the war. However, that’s not why we are here. W…
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
As many of you are aware about Scanpst.exe utility which is owned by Microsoft itself to repair inaccessible or damaged PST files, but the question is do you really think Scanpst.exe is capable to repair all sorts of PST related corruption issues?

590 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question