Perl Compress::Zlib and Scalar::Util problem

Hi,
    I am running SUSE 10 Enterprise server. I had installed a server (proserver) for a specific application and it was running well.  I updated my system and restarted it and when I try to rerun the server I got this error message and the server wont run . Upon checking up the problem it looked like there is some problem with the Scalar::Util and I might have to fix it up. I want to know how I could fix this problem/ how to reinstall Scalar:Util and restore perl with installed modules as normal before.

Thanks for any help

Below are the list of my commoand and error reports.


bioch2022:/usr/local/ensembl/Bio-Das-ProServer/eg # ./proserver -c myconfig.ini  is only avaliable with the XS version at /usr/lib/perl5/site_perl/5.8.8/Compress/Zlib.pm line 9
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/Compress/Zlib.pm line 9.
Compilation failed in require at ../blib/lib/Bio/Das/ProServer.pm line 17.
BEGIN failed--compilation aborted at ../blib/lib/Bio/Das/ProServer.pm line 17.
Compilation failed in require at ./proserver line 14.
BEGIN failed--compilation aborted at ./proserver line 14.


I checked for Zlib @

bioch2022:/home/ashgene # perl -MCompress::zlib -e 'print'
Can't locate Compress/zlib.pm in @INC (@INC contains: /usr/lib/perl5/5.8.8/i586-linux-thread-multi /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl .).
BEGIN failed--compilation aborted.

My Perl Version is

bioch2022:/home/ashgene # perl -V
.....
Built under linux
  Compiled at Nov  9 2007 13:34:11
  @INC:
    /usr/lib/perl5/5.8.8/i586-linux-thread-multi
    /usr/lib/perl5/5.8.8
    /usr/lib/perl5/site_perl/5.8.8/i586-linux-thread-multi
    /usr/lib/perl5/site_perl/5.8.8
    /usr/lib/perl5/site_perl
    /usr/lib/perl5/vendor_perl/5.8.8/i586-linux-thread-multi
    /usr/lib/perl5/vendor_perl/5.8.8
    /usr/lib/perl5/vendor_perl
LVL 1
haravallabhanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Adam314Commented:
Install the module with this command, running as root:
    perl -MCPAN -e 'install Compress::zlib'
0
haravallabhanAuthor Commented:
Hi,
 I did try to install Compress::Zlib but I get an error which basically says that it wont install without force.

a part of the error is here
# Looks like you planned 251 tests but only ran 3.
# Looks like your test died just after 3.
t/14gzopen......dubious
        Test returned status 255 (wstat 65280, 0xff00)
DIED. FAILED tests 1, 4-251
        Failed 249/251 tests, 0.80% okay
t/99pod.........ok
Failed Test    Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/000prereq.t     4  1024     7    4  57.14%  2-4 6
t/01version.t   255 65280     3    3 100.00%  1 3
t/03zlib-v1.t   255 65280   402  797 198.26%  1 5-402
t/05examples.t  255 65280    ??   ??       %  ??
t/06gzsetp.t    255 65280    ??   ??       %  ??
t/08encoding.t  255 65280    30   57 190.00%  1 3-30
t/14gzopen.t    255 65280   251  497 198.01%  1 4-251
Failed 7/8 test scripts, 12.50% okay. 683/694 subtests failed, 1.59% okay.
make: *** [test_dynamic] Error 255
  /usr/bin/make test -- NOT OK
Running make install
  make test had returned bad status, won't install without force
0
Adam314Commented:
Were you root when you ran it?
Is that the first error?


You could try to force install it... but if the tests are failing, then it likely means something is wrong.

To force install:
    perl -MCPAN -e 'force install Compress::zlib'
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

haravallabhanAuthor Commented:
I tried install it as SU before

The force install works and

cpan> install Compress::Zlib
Compress::Zlib is up to date.

cpan> install Scalar::Util
Scalar::Util is up to date.

Thanks! -*

But my Proserver  isnt running and giving the same error as before any suggestions please?
0
Adam314Commented:
Note that the module names are case sensitive, so Compress::Zlib is different than Compress::zlib.  Make sure you have the correct module installed.

What is:
    /usr/lib/perl5/site_perl/5.8.8/Compress/Zlib.pm line 9
    ../blib/lib/Bio/Das/ProServer.pm line 17

In your "perl -V", you removed the line giving the version of perl.  Do you have version 5.8.8 (revision 5 version 8 subversion 8)?
0
haravallabhanAuthor Commented:
Thanks

Zlib.pm has
Line 9 is
use Scalar::Util qw(dualvar);

Line 17 in Proserver.pm has
use Compress::Zlib;

my perl -V has
 # perl -V
Summary of my perl5 (revision 5 version 8 subversion 8) configuration:
  Platform:
    osname=linux, osvers=2.6.16, archname=i586-linux-thread-multi
    uname='linux stravinsky 2.6.16 #12 smp fri sep 7 17:18:37 cest 2007 i686 i686 i386 gnulinux '
0
haravallabhanAuthor Commented:
Excellent !
0
Adam314Commented:
So is it working now?  I hadn't had a chance to respond to your most recent comment.  What was it that fixed it?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.