Link lost, no logs ports still up

We have 3 sites and one site is losing connection to the others. All sites come in via VLAN4 on 192.168.10.1. through the ISP's 2950 to the 2821 VLAN4
We have been troubleshooting this now for a week, and have swapped the Cisco 2950 with a new 2950.
We have change ports that VLAN4 uses.
We have change cables.

The link state stays up. You cannot ping through from either side. If we take the link state down and back up on either routers the intersite traffic flows again.

I am going to move off VLAN4 and use the redundant GB port next time we go down.

I am going MAD trying to figure what could cause this connection failiure.


*********************************
Config
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname mk-cisco
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200 debugging
logging console critical
enable secret .
!
no aaa new-model
!
resource policy
!
clock timezone PCTime 0
ip subnet-zero
no ip source-route
ip tcp synwait-time 10
!
!
ip cef
!
!
no ip bootp server
ip domain name lsbd.local
ip name-server 172.16.0.21
!
username ciscoadmin privilege 15 secret
!
!
!
interface GigabitEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$$ES_LAN$$FW_INSIDE$
 ip address 192.168.169.2 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip route-cache flow
 shutdown
 duplex auto
 speed auto
 no mop enabled
!
interface GigabitEthernet0/1
 description $ETH-LAN$
 ip address 172.16.0.2 255.255.240.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 duplex auto
 speed auto
 no mop enabled
!
interface FastEthernet0/1/0
!
interface FastEthernet0/1/1
 switchport access vlan 3
!
interface FastEthernet0/1/2
 switchport access vlan 3
!
interface FastEthernet0/1/3
 switchport access vlan 4
!
interface Serial0/0/0
 ip address 192.168.20.1 255.255.255.0
 no ip redirects
 no ip proxy-arp
 ip route-cache flow
!
interface Vlan1
 no ip address
!
interface Vlan3
 ip address 172.16.16.2 255.255.240.0
!
interface Vlan4
 ip address 192.168.10.1 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.0.1 permanent
ip route 10.10.10.0 255.255.255.240 172.16.0.1 permanent
ip route 172.16.0.0 255.255.240.0 GigabitEthernet0/1 permanent
ip route 172.16.16.0 255.255.240.0 Vlan3 permanent
ip route 172.16.128.0 255.255.240.0 192.168.10.2 permanent
ip route 172.16.144.0 255.255.240.0 192.168.20.2 permanent
ip route 172.16.160.0 255.255.240.0 192.168.10.3 permanent
ip route 192.168.10.0 255.255.255.0 Vlan4 permanent
ip route 192.168.20.0 255.255.255.0 Serial0/0/0 permanent
ip route 192.168.168.0 255.255.255.0 192.168.10.2 permanent
ip route 192.168.169.0 255.255.255.0 GigabitEthernet0/0 permanent
!
ip http server
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
logging trap debugging
snmp-server community lsbd-mk RW
snmp-server community public RO
no cdp run
!
control-plane
!
banner login ^CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!

^C
!
line con 0
 login local
 transport output telnet
line aux 0
 login local
 transport output telnet
line vty 0 4
 privilege level 15
 login local
 transport input telnet
line vty 5 15
 privilege level 15
 login local
 transport input telnet
!
scheduler allocate 20000 1000
!
end

************************************************************

Logs of port (after 2 resets)

mk-cisco#show int fa 0/1/3
FastEthernet0/1/3 is up, line protocol is up
  Hardware is Fast Ethernet, address is 0019.e7a1.651b (bia 0019.e7a1.651b)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 01:13:21, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 360000 bits/sec, 426 packets/sec
  5 minute output rate 505000 bits/sec, 422 packets/sec
     3909406 packets input, 447496933 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     4023672 packets output, 851604603 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

*********************************************************

ANY HELP REALLY APPRECIATED!
MTSDLAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lrmooreCommented:
Can you post the config for the 2950? I'm thinking that they are not tagging traffic with vlan4 ID.. If that is the case, use VLAN1 on the router instead of vlan4 for the routed connection to the 2950. Else set vlan4 as the native vlan on the physical interface.

By the way, never ever add static routes to any directly connected networks..
 no ip route 172.16.0.0 255.255.240.0 GigabitEthernet0/1 permanent
 no ip route 192.168.20.0 255.255.255.0 Serial0/0/0 permanent
 no ip route 192.168.10.0 255.255.255.0 Vlan4 permanent
 no ip route 192.168.169.0 255.255.255.0 GigabitEthernet0/0 permanent
 no ip route 172.16.16.0 255.255.240.0 Vlan3 permanent

0
MTSDLAuthor Commented:
Hiya, Thanks for the response!

I have had to work out  a new way of working this out and so far it has worked.

I will explain fully and then if I could I would like some more info on what you mean on your response re direct connected networks.

/explaination

The Cisco 2821 has two GB ports, 0/0 had a legacy network connected (192.168.169.0 . 255.255.255.0)
0/1 Has the new network on it (172.16.0.0 . 255.255.240.0)

The Cisco has a 4 port ethernet switch as a module. This was divided into 3 VLANS (VLAN1 VLAN3 and VLAN4)
2 VLANS have IP addresses. VLAN3 172.16.16.2 and VLAN4 192.168.10.1

The Cisco has a serial cable module which links an unnumbered leased line and has been given an IP at each end. This is on 192.168.20.1

VLAN3 gives a secondary network access to all sites.
VLAN4 was the link to the ISP layer 2 network. (links to their 2950 so this is why I have not given the config)

****

What I have done.

config now
Current configuration : 2806 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname mk-cisco
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200 debugging
logging console critical
enable secret 5
!
no aaa new-model
!
resource policy
!
clock timezone PCTime 0
ip subnet-zero
no ip source-route
ip tcp synwait-time 10
!
!
ip cef
!
!
no ip bootp server
ip domain name lsbd.local
ip name-server 172.16.0.21
!
username ciscoadmin privilege 15 secret
!
!
!
interface GigabitEthernet0/0
 description $ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$$ES_LAN$$FW_INSIDE$$ETH-LAN$
 ip address 192.168.10.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip route-cache flow
 duplex auto
 speed auto
 no mop enabled
!
interface GigabitEthernet0/1
 description $ETH-LAN$
 ip address 172.16.0.2 255.255.240.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 duplex auto
 speed auto
 no mop enabled
!
interface FastEthernet0/1/0
 duplex full
 speed 100
!
interface FastEthernet0/1/1
 switchport access vlan 3
!
interface FastEthernet0/1/2
 switchport access vlan 3
!
interface FastEthernet0/1/3
!
interface Serial0/0/0
 ip address 192.168.20.1 255.255.255.0
 no ip redirects
 no ip proxy-arp
 ip route-cache flow
!
interface Vlan1
 no ip address
!
interface Vlan3
 ip address 172.16.16.2 255.255.240.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.0.1 permanent
ip route 10.10.10.0 255.255.255.240 172.16.0.1 permanent
ip route 172.16.0.0 255.255.240.0 GigabitEthernet0/1 permanent
ip route 172.16.16.0 255.255.240.0 Vlan3 permanent
ip route 172.16.128.0 255.255.240.0 192.168.10.2 permanent
ip route 172.16.144.0 255.255.240.0 192.168.20.2 permanent
ip route 172.16.160.0 255.255.240.0 192.168.10.3 permanent
ip route 192.168.10.0 255.255.255.0 GigabitEthernet0/0 permanent
ip route 192.168.20.0 255.255.255.0 Serial0/0/0 permanent
!
ip http server
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
logging trap debugging
snmp-server community lsbd-mk RW
snmp-server community public RO
no cdp run
!
control-plane
!
banner login ^CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!


^C
!
line con 0
 login local
 transport output telnet
line aux 0
 login local
 transport output telnet
line vty 0 4
 privilege level 15
 login local
 transport input telnet
line vty 5 15
 privilege level 15
 login local
 transport input telnet
!
scheduler allocate 20000 1000
!
end
***

I have removed VLAN4 and moved the connection to the port 0/0 which links to the layer 2 ISP router.

This has yet to lose connection after almost one full day.

\explaination

With the routing, is this still wrong in your opinion?

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MTSDLAuthor Commented:
No problems since changing.
0
Vee_ModCommented:
Closed, 500 points refunded.
Vee_Mod
Community Support Moderator
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.