MapPoint 2006 hangs at the Splash Screen

I have been using Mappoint for 3 years, first 2004, now 2006.  At the first install of 2006, somewhere after a successful install and operation, the Europe version started hanging.  I am using it as a ActiveX control in a C++ MFC app, so I thought it was something I was doing in my app.  So, I tried running it outside of my app.  It would hang at the splash screen.  I tried uninstalling/reinstalling the product (many times), but nothing has worked.  I've tried registry cleaners, etc, all to no avail.  I finally had to go to a new computer to continue developement.  Now, almost a year later, it has happened again, only with a new computer.  There is nothing in the application logs.  I am running XP Pro SP2 (in both cases).  The NA version runs fine.  Is there any debug messages that can be turned on to try to troubleshoot this problem?

Steve
rosenavAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
qz8dswConnect With a Mentor Commented:
Have you had a look at http://support.microsoft.com/kb/870630 as a possible cause?

"When you use any one of the other products that are listed in the "Applies To" section, you may experience the following symptom when you start the program:
"      The program stops responding (hangs). You see an hourglass. But the program never fully opens.

Back to the top
CAUSE
These problems may occur if the following components have been installed out of order, have not been installed, or if their installations have been corrupted:
"      The DCOM component
"      The JET component
"      The MDAC component
Excessive temporary files may have prevented a successful installation of these components."

A very long article, but it offers a possible way to fix XP and the exact order to do it.
0
 
DanRollinsCommented:
rosenav,
Did you try qz8dsw's suggestion?
0
 
rosenavAuthor Commented:
The actual solution was 2-fold.
1) qz8dsw: was right.  The database was corrupted.  To make matters worse, the reinstall has an error that has to do with Windows Media Player, and although it complains, it states it installs correctly, but leaves the database at filelength = 0.  Manually copying the database from the CD or from another install works.
2)  The other issue was my 2003 Visual Studio install had also been corrupted.  I still am at a loss as to why this happened, but reinstalling is how I fixed it.
0
 
qz8dswCommented:
Considering rosenav said I was partially correct in my post and we never heard back from them I don't see how I'm not getting at least a partial recognition.
Being able to help resolve a problem via the internet does depend on the feedback you receive.
0
All Courses

From novice to tech pro — start learning today.