How do I run .Net 1.1 and .Net 2.0 side-by-side

On our production site we have an ASP.Net 1.1 website
In preparation to roll out a new version (that uses 2.0) we installed .Net 2.0 on that machine. Immediately .Net 1.1 site stopped working with error:

Unrecognized attribute 'requirePermission' (C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Config\machine.config line 14)

I've seen a lot of ideas on the net but none that seem to fit. This website is at the top level so it's not contained in any other virtual folder.

If I go into the IIS admin and set it to run as ASP.NET version 2.0 then set it back to 1.1 and hit OK, that fixes it - but it's always broken again the next morning and I have to do it again. I suspect that's due to the application pool rebooting the .Net worker process.

One odd thing I see is if I view the properties of the top-level "Web Sites" folder in IISAdmin it says it's running ASP.NET 1.1 but it points to a config file in the 2.0 directory. See attached

I'm guessing if I fix this inconsistency I might fix the problem but am unsure how to proceed.
iisadmin.JPG
jerelmcdonaldAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

indianguru2Commented:
Run .Net 1.1 and .Net 2.0 in different Application Pools.
0
jerelmcdonaldAuthor Commented:
Thanks for the response. The .Net 1.1 site is in its own application pool. In fact there are no .net 2.0 sites on the machine, we just installed .Net 2.0 but haven't deployed any 2.0 website yet.

I think it needs aspnet_regiis run to clear up the conflict shown in the screen shot above (the properties screen of the "Web Sites" folder that contains all web sites. I'll try this tonight during off hours and report back although I'm not sure if that will make it worse or better.

I don't understand why I can set it to 2.0, then set it back to 1.1 and that fixes the problem -- until the next morning which I think coincides with the web application pool restart.
0
jerelmcdonaldAuthor Commented:
This fixed it:

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis i
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis -s W3SVC/1890615468/root/

Now I'll probably need to do some more work when I add the 2.0 sites - probably make the root 2.0 and go from there.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.