Mac/Dreamweaver local testing webserver configuration

Dreamweaver to develope - sites - testing server is on same iMac as local folders.  After putting file to testing server as configured by Mac Web Services (http://new-host-2.home/~username/).  I get Safari error - "Cannot connect to server"
Sharing/Web Services is running.  Tried (//localhost/), (//172.0.0.1/).  
SamSystems1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Eoin OSullivanConsultantCommented:
The default setting on OSX when web sharing is enabled ...
http://localhost/~username .... where "username" is YOUR short username in OSX


This will load the default home page located in \Users\username\Sites

0
SamSystems1Author Commented:
That's what i read, however my Web Services info page show:http://new-host-2.home/ as the main site and http://new-host-2.home/~username as the personal site with not way to change it.

I just configured the dreamweaver again to use //localhost/ and that is when I get the Can't Connect to //Localhost/   server error when I access via Safart.
0
SamSystems1Author Commented:
I am attaching screens.



temp-web1.jpg
temp-web2.jpg
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

SamSystems1Author Commented:
More points to help.
0
Eoin OSullivanConsultantCommented:
Sam

I am guessing you are part of some network which is allocating you this network name.  However when you try and use this name in the URL it is not resolving the IP properly hence the failure to connect.  Rather than mess with your DNS settings on your Mac which I guess are at fault in this situation.
I suggest you open Terminal and type  .. ifconfig
Take a note of the IP address of your ethernet card ... assuming you are connected to the network via cable it will probably be marked en0 or en1
Then is Safari enter the IP address followed by your username
http://xxx.xxx.xxx.xxx/~username

Personally I don't use the OSX built-in web sharing for website development.  Instead I use the FREE MAMP (http://www.mamp.info/en/index.php) this is an Apache webserver + MySQL  + PHP all bundled together.  It can be installed just by drag and drop into your Applications folder .. it does not install bits all over your system and once running has its own port 8888 so it doesn't interfere with OSX Web Server running on port 80.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Vee_ModCommented:
Force accepted.
Vee_Mod
Community Support Moderator
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.